PDA

View Full Version : Bad boog



Swamp Star
03-04-2010, 09:21 AM
My 93 boomerang has a 302 in it and I just put a new carb on it along with plugs wires cap points and rotor button. Its fine hooked up in the drive way or even sitting in the water Idleing but when you put it under a load its bogging down REALLY bad. At first I was thinking to much fuel, well I pulled the air cleaner off and when you get on it the fuel fan is just pettering out on the top end. What could I look for or do to try and get my boat back right. Season is coming on fast and I dont wanna miss a minute this year. Thanks in advance.

Suprahunter
03-04-2010, 09:53 AM
Try putting your hand over the front barrels of the carb at the same time the bog occurs. If it revs like normal the problem is in the carb. Also check the points adjustment if you have points.

PatL
03-04-2010, 02:52 PM
Also you may have water in the fuel which can also cause this type of condition. Have had that experience with a previous boat.

Swamp Star
03-04-2010, 05:57 PM
Thanks Im gonna try that. My boat does have points and I have just put new ones in it and set them to .0010 so that could be off a little there but my engine book say to set them with a static light and I dont have one.:confused: I think Im in for a few long hours of tuning on the water before any boarding will be done this year.

BRANDNIRON8971
03-04-2010, 07:51 PM
Swamp, I was having the same exact problem with a previos carberated motor. To make a really long story short, (a whole summers worth). The final result was that the alternator was on its way out and wasn't providing enough juice. I told the new owner that I thought that's what the problem was and he changed the alt. and the thing ran like a top...until he sank it.:(
Just an experiance I had. Who knows though

mmandley
03-04-2010, 09:09 PM
He sank it? Good gawd.

BRANDNIRON8971
03-04-2010, 09:18 PM
You know how Roosevelt gets on a windy day. Big monsoon came in and a four footer came over the bow. She was under for about two hours...and you lnow what pulled up, you got it a MOOMBA. After he got it up the fishfinder and I think the radio was still on. Crazy. Insurance covered it all. Talked to his wife a few weeks ago and she said it looks like a brand new boat again.

JesseC
03-05-2010, 05:27 PM
I had a similar problem with an older car we have, turned out to be water in the fuel, so we pumped the tank dry and refilled with new gas. Started it up and purred like a kitten, then we got on the gas and it bogged just like before. Turns out the fuel filter was full of water and not letting the fuel pass through quick enough. Try putting some water treatment in a full tank and run a new fuel filter.

Swamp Star
03-10-2010, 04:35 PM
I will try all of what yall said as soon as it quits rainin. Where is the waterfuel separator on a boat like mine? I havent seen it when I have looked for it. 93 boomerang.

h2oskierrick
03-13-2010, 12:48 AM
One other thing to look at is the boat running extemely rich? If so, lack of power and bogging can be caused by a blown power valve. This would be located in the front float bowl of the carb between the metering block. This happened to us, all it takes is one small backfire through the carb to blow this out. Good luck.