PDA

View Full Version : Engine in protection mode



Tro
03-05-2010, 09:47 AM
Hi, I am looking for clues since my engine sets itself in protection mode, check engine light is on after a normal start up and running smoothly on idle.
This week I did engine cleaning, greasing, painting and probably disable a probe or cable ?? Any one of you having idea.. Nevertheless, I expect to have somebody to check it with a computer to read the current default.
Thank you

DOCDRS
03-05-2010, 09:56 AM
please keep us posted with the fix

Ian Brantford
03-09-2010, 11:03 PM
Check for low gear oil. There should be an alert light for it on the wall by the driver's right knee. It will say something like "you are screwed if this light is on when engine is over 1200 RPM".

Tro
03-12-2010, 06:47 AM
Thank you to those who took time to answer. As suggested here is the explanation and how did we fix the problem.

That was the Check Engine light which was illuminated due to faulty message from the engine control module (ECM MEFI 5), do not confuse with the warning light dedicated to the V drive.

The engine started and maintained idle perfectly but was unable to spin up,the ECM was in self protection mode.

Thanks to one of my friends who has the software and the plugs to connect the engine, we could read the diagnostic trouble codes, saying that the manifold absolute pressure sensor was guilty.

I was guilty because I probably disconnected the sensor while doing some cleaning, and the ECM memorized it....

After reading the codes, we erased them, start the engine and no more self protection mode, yesss.

Her is a link with document giving the full details on the ECM MEFI 5:
http://www.marinepowerusa.com/Products/PDF's/MEFI_5_Diag.pdf

kaneboats
03-12-2010, 08:45 AM
Wow. That's some manual. I'll have to save it for my Saturday night reading. Good stuff.