PDA

View Full Version : Swim Platform Rubber surface



ffmcdou
03-08-2010, 08:24 PM
I have an 08 Mobius LSV. The rubber surface on the swim platform is I guess weathering alittle. It this causing an Fing mess. Everytime anyone enters the boat from the back, it tracks black footprints all over the boat. Any suggestions for treating the rubber would be appreciated. Mother's makes a rubber restoration product (wax type stuff) that helped but didn't fix. Thanks.

brain_rinse
03-08-2010, 08:29 PM
I'm guessing most will tell you to upgrade to a SeaDek pad. They are softer, cooler, and can be color matched. This was a common problem (though I thought it was fixed by 08) and I don't recall anyone ever finding a real fix.

byronkoz
03-08-2010, 08:48 PM
I use gator grip and really like it. I've also put it other places on the boat to stand on and for protection.

deepcove
03-08-2010, 08:50 PM
I have a 2004 that has been doing the same thing since the second year I owned the boat....which is why I recently participated in the seadek group buy.

Mikey
03-08-2010, 09:29 PM
I haven't yet but probably plan to this summer switch to Sea Dek but for past years , i've used clear laquer sprayed on from a can which has worked surprisingly well. A little slippery the first couple uses but not bad after that and no more black footprints.Just spray the rubber.tape the rest off and it works and looks good.

yearround
03-08-2010, 09:31 PM
I replaced with gator grip before the seadec was out. Either are much better than the black. I thnk my gator grip was about 100? Don't remember.

New Guy
03-08-2010, 09:51 PM
I going to try the gator grip. We'll see how the summer goes.

gus 08 mobius lsv
03-09-2010, 06:20 PM
i bought my 08 lsv in june of 09 first two times out i had a mess all over my seats. my cousin had some simple green on his boat and used it while on the water with a scrub brush. never had an issue the rest of the summer with it but still got a sea dek pad so if your not looking to upgrade yet it worked wonders for me.

kaneboats
03-09-2010, 11:33 PM
SC thought they had the "problem" fixed in 08 when they switched vendors, but 6 months after I bought my 09, I had the "problem" too.

Hmmm. The "problem" sounds like a warranty item. Don't I sound like a new boat owner now?