PDA

View Full Version : Stargazer



tazz3069
04-11-2010, 05:19 PM
I worked on the boat today to get it ready for the up coming warm weather. I went to start the engine and noticed that the display is not working on my Star Gazer. looked for a fuse and could not find one. What the heck. Now something else I have to fix. Has anyone ran into this problem in the past?

Laz
04-11-2010, 09:02 PM
This often happens if it's cold. So far, after a few minutes, it always comes back.

Laz

tazz3069
04-11-2010, 09:45 PM
I keep my boat in the garage all the time. When I turn the key, all the other gauges work. My Stargazer display is dead. No LCD screen and no back light. I hope that I do not need to get another unit. I am going to give customer service a call on Monday. Very weird. I did absolutely nothing to the electrical over the winter months. I will post my results when I get off the phone with them Monday.
Mark

Sled491
04-12-2010, 12:46 AM
Seems like PP quirks aren't limited to regular "Wakeboard Pro" versions.
Hope it's not anything major.

tazz3069
04-12-2010, 10:35 PM
Talked with the guys at PP this morning. I need to give them my seriel number off the Main Unit. The tech told me that I may need to buy another Main Unit. I can not believe this. I have only used it for two seasons, and the $1000.00 I spent went down the drain. He did tell me that I will get a good deal on a new one. Not very happy right now. I will find out tomorrow when I call with the seriel Number what type of a good deal I will get.

Sled491
04-12-2010, 10:43 PM
What? How does every one get new modules for the Wake board Pro and you have to buy a new one? That doesn't sound right.

tazz3069
04-12-2010, 11:05 PM
That's what I'm talking about. I will find out in the morning.

tazz3069
04-13-2010, 11:35 AM
Well I just got off the phone with perfect pass this morning. I gave them the necessary information they needed and he came back to me with a cost. He told me that the main module was fried. He had asked if I have some sort of battery charger on the boat. I told him that I have a trickle charger. He said, there could have been a surge in the system and that what fried the module. I do remember turning the perko switch on, one day, to check the LED, stereo. I did not even think to unplug the charger. Well I guess a lesson learned.

Mark

Sled491
04-13-2010, 12:00 PM
For a 125.00 not bad, and you an electritian :)

Hows the solar business going?

We're slow out here that's for sure. But then the Midwest is always 6 mnths behind the rest of the nation.

tazz3069
04-13-2010, 12:11 PM
Nothing has happened yet with the Solar. Out Power Company out here need to get their head out of the A@!. They are telling us that there is no more rebates for 2010. As a matter of fact, the rebates for 2010 ended mid 2009. I have had my application in there for almost two years now and have heard nothing. Even being a contractor, I can not even get the rebate. They will accept applications for the rebate for 2011 at the end of this month. That means, if people want the rebate of $10,500.00 they need to wait until next year to purchase the system and receive their rebate. I am writing a letter to Obama in regards to the energy rebate here in Vegas. One of our representatives, which will remain nameless, is the biggest A$# ever. He has a partial control of the power company. So which means, more rebates out, less money in his pocket now. Our Governor is no big help either. He his too busy taking care of other personal issues (mistress) and not doing his job. I can hardly wait for the elections.

zabooda
04-13-2010, 12:30 PM
Tell PP to put a voltage regulator chip in their device to prevent over-voltage. For a Grand you would think a 10 cent part would be worth it. IMO, that is the poorest excuse a company can make and the second worst is logic systems intertied with other logic systems and fail to communicate with each other (Toyota?). You don't stay in business very long with basic system failures.

Sled491
04-13-2010, 03:01 PM
Z I bet the part whole sale is more like a buck per thousand.

Tazz I feel your pain. The government and I'm not opening a whole can of worms here has done little to help our industry, yet the bailed out an auto maker, and insurance company, and a whole smack of lenders that got us here, and yet....absolutly nothing for the middle class construction business owner, those hit the hardest. I though liberals were about protecting the middle class :(

That being said you can see the signs on the wall, many many incumbents are loosing there seats just because people want some one uncorrupted, and I mean Dems and Rep's

tazz3069
04-14-2010, 12:07 AM
I agree. Big banks got bailed out, big car manufactures got bailed out, Ford did not take a hand out, Kudos to them ( I still love my Dodge Mega Cab), But middle class blue color works get s swift kick in the Hind Side. I think that we should have been taken care of first. We are the reason for the economy. Now that Credit Cards of ramped up their interest rates to 29.6%, people are not spending anymore. Anyway, enough of the political BS. I will still push on and continue my business and make people very happy with my final product and customer service. I am very hopeful of the future.

Sled491
04-14-2010, 12:18 AM
Amen Brother, lets hope for the future!

tazz3069
04-14-2010, 10:21 PM
Got my new module today. I ordered it yesterday and it came from Canada. Wow that was fast. i will put it in this weekend.

Sled491
04-14-2010, 11:40 PM
Wow that was fast.

tazz3069
04-15-2010, 07:53 PM
Wow I am such an idiot. I thought my module was fried. Well I connected the new one and nothing. Not even a blink of the light. I was sooooooo pissed. I checked to see if there was a fuse I missed. I checked to see if there was a wire that corroded. I check to see if a connector came loose. Nothing absolutely nothing. What the heck am I missing here. I looked over to my throttle lever and there it was. This could not be my problem. I shut the key, turned off the batteries, and plugged in my lanyard. Turned the batteries back on and turned the key. I could not believe it, it worked. I turned everything off again and plugged in the old module. Turned the key and the screen kicked on. I just do not understand why the PP would be connected to the same circuit as the cut off for the motor? HUMMMMMMM. Oh well, I am going to be calling them in the morning to see if the unit can be returned. If not, I will post it in the classified section.

Tazz

I need to drown myself in a beer now.

tazz3069
04-15-2010, 08:06 PM
Sounds good too me. I just might sell it. I did pay around $1k for the unit two seasons ago. So yes, at the price I got it for, you can not go wrong. PLACE your bids.

Sled491
04-15-2010, 09:46 PM
Man that just sucks, something so simple. You should call PP back and get another one, then get yourself a little online PP business going :D JK

ausbill32
04-16-2010, 11:37 AM
Wow..that was a good deal. I just forked out $1000 and some change for my stargazer a couple of weeks ago. I like it a lot better than the wakeboard pro paddle wheel I had on my last boat. You should be able to sell that and make some money.

I had a similiar story with my red lanyard key getting pulled out while I was driving my last boat in the middle of the lake. Just crusing along and all the sudden the boat completely died. I think I spent an hour checking every wire connection on the boat only to find out my book of CDs that I shoved in between the drivers seat and the hull panel had slid forward and knocked my red lanyard key out which killed the engine. I got a chuckle out of it later on but at the time, I was so annoyed...lol.

kaneboats
04-16-2010, 04:06 PM
I did that on my first boat. Screwed around for an hour and then decided to start at the beginning. Ah HA!!!

Sled491
04-16-2010, 09:04 PM
Happens every year with our small 9.9 Merc. Yank on that thing for 15 minutes then remember the tether :)

tazz3069
04-17-2010, 12:20 AM
Funny how this happened. I NEVER TOUCH THAT STUPID THING. I do not even remember pulling the lanyard. Wow I must be getting old.