PDA

View Full Version : New ballast complete!



stretch55
05-02-2010, 01:25 AM
I finished the install of my new ballast systems today. It took me 12 hrs to install. It consists of 3 1" through hull intakes, 3 1" ball valves, 3 tsunami 1200 pumps, 3 1" vented loops, all 1" intake lines. On the drain side I installed 3 "Y"s with 3 3/4" one way check valves. I have 1400 lb system, 2 400lbs in the rear and 1 600lbs up front. I am hoping to water test it tomorrow. The sealant should be set since I did the through hulls on Friday. I will post some pics soon. I will also let you guys know my new fill time vs my old fill time.

newty
05-02-2010, 02:35 AM
Congrats! Def want to see some pics. ballast is on my list to do for sure! Love to see a good DIY mod.

badasshybrid
05-02-2010, 02:48 AM
I would like to see the pics to. Been thinking about installing some ballast in my Outback but have no idea where to start.

brain_rinse
05-02-2010, 11:59 PM
Nice work! I think you'll be happy with the performance of your new system.

cab13367
05-03-2010, 12:20 AM
Nice work! I think you'll be happy with the performance of your new system.

Dan,

Have you had a chance to test out your ballast upgrade, and in particular, does the check valve prevent the rear bags from filling when underway?

Thanks,

Al

brain_rinse
05-03-2010, 11:19 AM
Dan,

Have you had a chance to test out your ballast upgrade, and in particular, does the check valve prevent the rear bags from filling when underway?

Thanks,

Al

Funny story... OK, not really funny. But long story short I found a defective section of spa hose that split right down the middle. I have no way of knowing if it's just that one spot or if all the hose will eventually fail. It's crazy because this hose is so strong it was very difficult to even cut. But this piece just split right down the middle! So I'm probably going to gut all the hose and replace it. So no, no water test yet. :(

stretch55
05-03-2010, 01:10 PM
Well I didn't get a chance to water test the new system yesterday. Looks like I won't get to until Friday.

stretch55
05-09-2010, 12:58 PM
Ok, finally got to test the new system out yesterday. I have a 1400lb system. 2 400lbs in the rear and a 600lb in the front. Starrt to finish on the fill time with the 3 new tsunami 1200's and all 1" lines was 6:00 flat. I think that's pretty freakin good. That's 100lbs per min.

newty
05-09-2010, 01:15 PM
100lbs a minute! I cant even get that weight in friends on the boat that fast.:p
Glad it worked, post some pics!

cab13367
05-09-2010, 01:46 PM
Stretch,

That's awesome! Glad all your hard work paid off. Did u happen to time ur fill time with the stock system?

Al

stretch55
05-09-2010, 07:45 PM
Stretch,

That's awesome! Glad all your hard work paid off. Did u happen to time ur fill time with the stock system?

Al

It was right around 14min.