PDA

View Full Version : Discovered a flaw in my dealer installed GGIII upgrade



you da man
06-08-2010, 01:23 AM
Well today I was out on the boat with my new 1100lb sacs in the rear locker and the 1100lb sac in the center. Filled up the goofy side (driver side) for surfing and the wake was impressive (I'll post up another thread about it). Went to drain the starboard 1100 sac and nothing would drain. Lifted up what we could of the 1100 sac where the drain hose was and there was no kink. However, discovered the hose was too long and then opened the engine hatch only to see that whoever installed the drain pump installed it level with the floor of the rear locker. So the drain pump couldn't prime with the slightly looped drain line and no gravity to force the pump to prime. We shook the bag and I litterally stepped on the bag to try to force water in the line to prime the pump...nothing happened but you could here a gurgling sound as if the pump was getting a tiny bit of water but not enough to create pressure. Finally, I disconnected the vent/overflow hose from the top, told my buddy to put the palm of his hand over it and then I hit the fill switch. It was already puffy full but I thought maybe if we kept the water from coming out the overflow it would force it in the drain line....IT WORKED. Now I'm just going to take the boat to the dealer and explained what should have been done...I know I can easily cut 8-10" off the hose and remount the drain pump about 3" lower but it's the principle.

sandm
06-08-2010, 10:41 AM
I'd want to do the same thing, but the 60mile round trip would probably just have me call them on the phone, complain a little and then do it in the garage myself :)