PDA

View Full Version : DIY Shower Install



newty
06-24-2010, 09:55 PM
I've done a few of these for some folks and did one in my boat. I just finished one up for a buddy and figured I post a how too for ya.
For reference this is an 06' Moomba LSV.

As for parts its kinda tough finding all the stuff you need unless you buy the kit from heatercraft.
I did order the mixing valve with the switch from them for about $75.
Most of the pvc and standard plumbing parts you can find anywhere. The pressure fit fittings and the tubing you can get from an industrial fittings supplier. The fittings that attatch to the pump and mixing valve can be picked up at West Marine.
The pump I got from a RV shop. Its just an on demand pump that turns on when the pressure drops well... like an RV.
For the shower hose I prefer the coiled hose. It doesn't take up much room, can be squished by the fatsacs and bounce back. You can usually find the hose and head as a kit anywhere.
All together the parts cost about $250. I believe the Kit with everything you need can be purchased through Heater Craft for $350ish?

Enjoy!

First I removed the where I will mount the pump and mixing valve.
Next lay out the two and find the best orientation that best fits the panel.
Cut a hole for the mixing valve and mount the valve in the panel.
Mount the pump to the panel.

newty
06-24-2010, 10:11 PM
Next thing I did was wire the pump to the switch.
Plumb the pump suction to the mixed hot cold outlet.
Add the shower hose to the discharge of the pump.

Now back into the boat for the water tie-in.
First locate the impeller and find discharge side hose. Typically its the top hose that runs over to your trans cooler. This will be your cold water supply to the shower.
Cut out a 2" section and install the fitting leaving the hose clamps loose so you can adjust it once its in place (this is easier done after removing the hose completely).
I used a 1 1/4" barbed by barbed by 3/4" NPT PVC fitting for my tie-in.
Next locate the 3/8" brass plug on the drivers side of the engine block about 2" above the oil pan. I believe its a 9/16" so use a socke or box end wrench. if not you will round it off or strip it.
Remove it and install your valve. You don't have to use a valve but if something were to happen I like knowing I can isolate it.
This will be the hot water supply to your shower.

newty
06-24-2010, 10:19 PM
Install the panel and make the connections. I have red and blue 3/8 air hose so keeping the hot and cold seperated was easy.
I then fused the switch and got a 12v tie in at the alternator.
If you guys decide to do one on your boat you'll love it. I'll never have a boat w/o one.
Super easy install with the exception of finding all the parts. Took me about and hour and a half start to finish.

walb0244
06-24-2010, 10:27 PM
That looks sweet. I like that place for a install. Don't have to drill any holes in the hull or anything. Pretty nice location. Will have to keep this in mind. Just haven't decided if I want to do this or not. I was trying to decide if I wanted one of these so I took a container of hot water and poured it in my wetsuit. When I poured the hot water in the water just came out the bottom of my wetsuit. So not sure still.

MartinCaron
06-25-2010, 09:14 AM
good job newty

squeeg333
06-25-2010, 11:26 AM
Newty, yet again, thanks man! A shower is on my "getting shorter" list of things to do to my boat. I agree, I won't own a boat without one! I have been trying to figure out where to put the pump and mixing valve, and I really like where you put them. NIce and discreet and out of the way!

Yet again one more mod that didn't require a sewing machine...

Oh, and just an fyi to the DIYers out there - skidim.com has the Heatercraft setup for 257. So, right along the lines of how much Newty paid to do this. Just an option!

And one more fyi - skidim.com is running a 10% off promo. It'll hurt, but use the word MALIBU to get it!

cab13367
06-27-2010, 10:28 PM
Newty, great write up! But for the type of boating that we (I) do, I don't see a need for it. You say you wouldn't own a boat without one. What exactly do you use it for?

Thanks,

Al

KurtL
06-28-2010, 01:27 AM
Newty, nice post! We have the aquatek shower kit on our boat and love it. It takes the bite out of early morning skis when it's 45F and water is in the mid to high fifties. It lets you get over the chill so you can pull the next skier.
A nice accessory (a must if the wife is getting in the water before July) in the Northern States and Canada.

newty
06-30-2010, 02:30 PM
Al, we use it all the time.
1. We spend a lot of time at the beach so the kids are always sandy.
2. Warming up a wet suit.
3. Warming up after a cold dip.
4. Uh... showers.:p When we camp of course.
5. Ever moore on a dock that is covered with goose greese? Its a wash down pump too!
6. Filling water ballons.
7. Spraying the girls on the beach or the boat next to you with cold/warm water.
8. Wet t-shir... never mind.:D

Just to name a few.

squeeg333
07-06-2010, 01:37 PM
Well, I got my shower installed on the 4th, and tested it out yesterday. It's awesome. The control knobs have been a bit tricky to get the handle of. I've got the 100S controller, which is somewhat different than the one Newty installed. I also made some changes to the install over what Newty did, but unfortunately, didn't take copious photos during the install. I'll get some shots later this week of the finished product, to give a different perspective on where you can install things.

newty
07-08-2010, 09:38 AM
Cool! Glad it worked for ya!

deafgoose
04-26-2011, 12:22 PM
Hey newty!

Where did you purchase your shower kit?

I cant seem to locate the Aquatik kit with the power switch on the face plate.

bbuhtz
04-27-2011, 08:19 AM
You may find some stuff that your looking for here deafgoose.


http://www.heatercraft.com/category.aspx?categoryid=20&startpage=0

newty
04-27-2011, 08:56 AM
I got all the parts locally, but I had to order the faceplate from heatercraft.

skidim.com has the kits as cheap as I've seen them but they do not have that kind of faceplate. You may want to contact them and see if they can get that faceplate with thier kit.

wakeupcall
04-27-2011, 10:58 AM
Here is one on ebay that might be worth a look
http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=230565641384&viewitem=&sspagename=STRK%3AMEWAX%3AIT

newty
04-27-2011, 11:27 AM
Thats a great price!

deafgoose
04-27-2011, 03:56 PM
I just won the bid for a brand new shower system on eBay for $107.50 + shipping.

Now I am going to order the upgraded faceplate with power switch from Heatercraft.

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=200601352388

501
05-09-2011, 06:01 PM
Living in Canada sucks when they won't ship to us. The guy selling the heaters for $229 on ebay wont ship to canada. I am waiting for a call back from my local boat shop so we'll see what kind of pricing they give me.

Sea N' Things
05-09-2011, 11:33 PM
Hey 501, call me I may have a heater for you

501
05-10-2011, 01:34 AM
Sea N' Things, I'm sorry, I totally forgot to call you. I will give you a shout Wednesday.

Tomorrow myself and a few friends have taken the day off and are headed to Alix lake for our first ride of the year. I will put some pictures up tomorrow. Phone will be off except for emergencies. I can't wait.

Thanks a lot.

newty
05-10-2011, 08:43 AM
But this is a shower thread....;)

Grant M
05-10-2011, 03:14 PM
Sea N' Things, I'm sorry, I totally forgot to call you. I will give you a shout Wednesday.

Tomorrow myself and a few friends have taken the day off and are headed to Alix lake for our first ride of the year. I will put some pictures up tomorrow. Phone will be off except for emergencies. I can't wait.

Thanks a lot.

Heading out already - Fantastic.
What's the lake ice situation down there?

501
05-11-2011, 01:04 AM
Alix was ice free and great. Sylvan has about 200 feet of open water along shore. I'd say another 10 days till we can ride here.

deafgoose
05-17-2011, 11:37 AM
Install the panel and make the connections. I have red and blue 3/8 air hose so keeping the hot and cold seperated was easy.
I then fused the switch and got a 12v tie in at the alternator.
If you guys decide to do one on your boat you'll love it. I'll never have a boat w/o one.
Super easy install with the exception of finding all the parts. Took me about and hour and a half start to finish.

Hey Newty!

I am just about to tackle my shower install and the only part I don't understand is how to fuse the switch and "tie in" at the alternator.

Could you explain that step in a little more detail?

Thanks!

newty
05-17-2011, 11:49 AM
Yea, you just need an inline fuse added to the switch power to protect it and the pump. As far as the tie in, if you look at the alternator there is a 8ga or so orange and and a 8ga black wire that come off the alternator. You just need to run the ground from the pump to the ground side or black post of the alternator (and the switch if its illumnated) and the power side of the switch to the positive of orange side of the alternator. If you are uncomfortable running the power to the alternator you can also run the ground to any bolt on the block for ground and run power to the main battery cable on the starter. The alternator is very close and convenient, and if follow the orange wire, it goes to the starter anyway to charge the batteries.
If your really worrid about it landing the wires back there, you can always run a set up to the helm buss for ground and power.
That answer your q's?

deafgoose
05-17-2011, 12:42 PM
Great. That info helps.

Heatercraft sent me the same faceplate you have but with the power switch on the left instead of the right. (not sure why)

There is nothing marked on the back of the power switch so does it matter where the positive/negative connection is?

Also why are there 3 terminals on the power switch. What is the 3rd one for?

http://dl.dropbox.com/u/26003034/shower1.jpg

http://dl.dropbox.com/u/26003034/shower2.jpg

newty
05-17-2011, 01:49 PM
One is a ground because when the switch is on it illuminates.

Use an ohm meter to check which pins do what.

I believe the top offset pin is the ground, the bottom one is power supply and the middle is switched power. I'm not completely sure.

I ended up using an ohm meter to check but if you don't have one you can pop the back of the switch off and look at how it works. You will see how when the switch is down it is disconnects the bottom pin from the middle pin. When its switched on it connects the two pins and sends power to the light and the ground completes the circuit. Pull it apart and look if you're not positive how it works.

If you have the power in and out backwards then the light will stay on all the time but if you have the power and ground backwards you'll ruin the switch. Once you think you have it figured out bench test with a light fuse it to be sure.

davinci
05-25-2011, 09:59 PM
How exactly does this shower work, how long does it take to heat the water , how much hot water can one use at a time , how much pressure do you have and is it the lake water ?? Sounds like an interesting contraption .

newty
05-25-2011, 10:14 PM
Davinci, You use lake water. The cold side is fed off the pressure side of your impeller and the hot side comes off the block drain. They are combined in the mixing valve and pulled through the pump and pressured through the shower head.
As long as the boat is running and warm you will have hot water.
In fact if you don't use a little cold water, you will burn yourself.
I think its a must up here in the north.

davinci
05-25-2011, 10:30 PM
Thanks newt..I'm ordering one tomorrow

davinci
05-25-2011, 10:39 PM
Sorry newt but I have another silly question.
Why do you need a pump if it gets pumped from the motor.

newty
05-31-2011, 02:56 PM
I think guys have tried it but I don't believe there is enough pressure to make the water spray properly through the shower head.

squeeg333
06-06-2011, 01:12 PM
So, I said a while ago I was going to post photos of my shower install - it just took me almost a year...

I did it slightly different than Newty, and just to give you guys other ideas of mounting options.

I mounted the pump on the rear board that encloses the engine - sorry, not sure how to describe it. Anyway, the photo shows what I'm talking about. The pressure and suction lines come off of the pump, and are rounted behind the 4" vent tubes. This keeps a really clean install, and lets you secure the hoses.

I had a slightly different contol than Newty as well, so I mounted it in a different location. I used the same side "curtain" that he did, but you can see that all the hoses are still well hid.

This one was a fun install, and pretty straight forward.

newty
06-13-2011, 09:31 AM
Thats the same mixing valve I have in my boat.
Looks good man. Nice and clean.
Hows that pump location going to be for your impeller change on the motor?

squeeg333
06-22-2011, 01:38 PM
First time I tried to adjust the control knob for temperature I had all sorts of water coming out of it. Not sure what the heck that was about. I thik I might have had the knob WAY too open. It doesn't leak at all now. It's pretty solid. Interested to see how the new 750's work with it sticking out like that. The old sacks fit just fine, but these biggers ones, well, we'll see!

The pump location is no problem for impeller change, or really anything at all. It's high enough above everything to be totally out of the way. I'd say the hose connections are right about at the top of the muffler, or close to it, so it's pretty far from anything that might get in the way. At least, so far!

millerda68
07-12-2011, 01:35 AM
Thanks for the post, helped me to get my shower installed this past weekend. I was stressing a bit since the forum was down, but remembered the pics you posted and got all in and working. Took about 3 hours to do everything, but now that i have done it once, future installs will only take 90 mins max.

newty
07-12-2011, 08:51 AM
Glad it worked for you!

mnpracing
07-12-2011, 09:06 AM
silly question, but how do you guys use the showers? Is it to warm up when you've been in cold lake/river water, is it to actually get clean? I think it's a neat addition, just not sure how/when I'd actually use it.

iwaterskihard
07-12-2011, 12:36 PM
Newty I installed my shower the same way you did but was going to switch the hot water from the block to the pump as I don't have very much water pressure in my shower unit.
The knobs are tricky and I am having trouble with the adjustments as it's either 185 degrees or lake temp.

Any suggestions?

Thanks

squeeg333
07-12-2011, 02:00 PM
The best use for the shower is on a cold day, especially if you've got a wetsuit on. Fill it with warm water before you hop in, and if you're quick enough, by the time you're up, the cold water hasn't leaked into it fully. Then, when you get out, you can warm yourself back up. It's amazing. Also works well to warm up cold or wet life jackets for that first band-aide tearing touch to dry skin...

But you can also use it as a real shower, like when camping or whatever. And the cold setting works well for hot days late in the season when the lake is fairly warm... using that cold water just hits the spot.

Not to mention the jet setting on the showerhead - good to shoot buddies with!

newty
07-12-2011, 03:24 PM
As far as pressure, the pumps you get with the kits aren't going to be high gpm pumps. I used a 4 gpm rv pump. I think the standard is a 2.5. So from what I gather, you have cold water flow and hot water flow but no in between. I usually turn the pump on then the cold all the way and then slowly and incrementally turn the hot up untill you get the desired temp. The valves are tricky especially with a lower flow pump. It just takes longer for the temps to change and when they do you've likely gone passed the sweet spot.

Once you have the temp set, leave it alone and dont touch it except to make very minor adjustments, but only on the hot side... even when it's off. Just make sure the valve on the showerhead is off and the switch is off.

I installed one for a guy here about a month ago and the hot side wouldn't flow at all. turns out the bottom side of his block had sand in it and had plugged the mixing valve.:confused: That cost him an extra hour of labor!:D Be sure your hoses are all clear.

millerda68
07-13-2011, 12:08 AM
We used it this weekend mostly to warm up after being in the water. Also the second person in used it to warm up the used life jackets. The wife has been begging to go camping. I need my morning shower and my morning coffee. The plan is to camp by water and I now have a warm morning shower available.

newty
03-06-2012, 08:53 AM
Lots of request on this so back to the top. I reloaded all the photos that were missing.

Brettwallace
03-23-2012, 03:55 PM
I followed this install last fall. Worked great. We use it all the time for warming up wetsuits and cleaning off feet. Thanks for the write up!!

newty
03-24-2012, 01:39 AM
Good to hear. Gald it helped!

millerda68
07-02-2012, 05:23 PM
Is there any kind of fuse or reset on the pump? I was out on Saturday in the crappy weather. Turned on the shower once and all worked perfectly. Tried to turn it on a bit later and use it, nothing. Light on the switch is coming on and power is working, just seems like the pump died.

It has been in the boat less than a year and only used a dozen times or so. Thought I would check here first for any possible troubleshooting.

Thanks!

squeeg333
07-02-2012, 06:48 PM
I don't recall there being any sort of reset or fuse on the pump body itself. On my install I put an in-line fuse on the power to the pump just to be sure if something were to get sucked into the pump, it would pop the fuse before destroying everything.

One thing that comes to my mind is possibly a clogged mixing valve, much like Newty was talking about above with a buddies hot water not working. I'd pull the hoses off of the back of the mixing valve a take a look. Then, if that's clear, check the hoses coming off of the pump, maybe something did get stuck in there.

When I winterized this past year, I noticed that there was some buildup of debris on the hot-side screen of the mixing valve. Since I've got the hot water coming from the block (I assume you do as well), that tends to have some debris in it from corrosion inside cooling jacket of the engine. Not a big deal, just a likely culprit for low or no flow.

That's all of course after checking the in-line fuse that you put on with your install - if you put one on that is.

millerda68
07-30-2012, 04:59 PM
Checked the wires, checked the fuse. The pump died. I ordered a new one and was able to slap it back in and am back in business again. Figured I would send the old pump in and see if it can be serviced or not. If so, then I have a spare on hand.