PDA

View Full Version : Bilge Light not coming on, bilge not working



cachais
07-04-2010, 12:33 PM
Sorry if this is a repeat, but I read through all the other Bilge posts and they all seem to have the light working on the dash, but the Bilge not working. My light is not coming on when the switch is flipped on the dash and the bilge is not working. It is an 08 DD. This is my first boat so sorry if it is a dumb question. My kids have been in the boat flipping switches, not sure if that broke it or not. Any ideas on where I should start in fixing this? Thanks!

AaronWhitt82
07-04-2010, 05:06 PM
Sorry if this is a repeat, but I read through all the other Bilge posts and they all seem to have the light working on the dash, but the Bilge not working. My light is not coming on when the switch is flipped on the dash and the bilge is not working. It is an 08 DD. This is my first boat so sorry if it is a dumb question. My kids have been in the boat flipping switches, not sure if that broke it or not. Any ideas on where I should start in fixing this? Thanks!

Sounds to me like it isn't getting power.... I would start by checking the rear of the switch and making sure the wires are still hooked up to it. It is possible that a wire could have come off.

gcnettl
07-05-2010, 12:30 AM
Should have a circuit breaker. If it is tripped then the switch will not be getting power to it. The breaker is usually located around the switch. Simply press it in, much like reseting a breaker in your home.

cachais
07-05-2010, 05:00 PM
Thanks gcnettl!!!!! That was it. Got under it with a flashlight and pushed the breaker and that did the trick. Thanks again!