PDA

View Full Version : Gravity III Ballast Bag wiring issue



MAPWPD
07-10-2010, 10:50 PM
I have a 2008 Moomba Mobius LSV the other day my left ballast bag stopped working and the lights for fill and empty but still no power to either pumps. I tried the using that switch elsewhere to find out if the switch was broken and it seems that they all work fine. I used a test light and found when I compared the results from the two working switches I found two wires not getting any power the solid brown and orange with a strip located in the middle of the switch on the left side looking at the front of it. So I left them disconected overnight and today when I had my more expirenced electronics friend over we double check all I had found out and re tried the swapping of the wires and switches. Now after we were done the left bag nothing and the front just lights only. Which made me excited because now my right bag only works. HELP. I am trying to locate a wiring diagram, I track the wire till I loose it heading down into the hull of the boat. We also tried replacing the relay next to the switches and all the breakers. I had installed a new amp and tower speakers and had too tighten down the main breaker near the battery.

Thanks for any and all words of wisdom......:confused:

gcnettl
07-11-2010, 11:51 PM
I had to install a new fuse block in mine. Basically where the blades of the fuse made contact, the contacts were just not carrying the load anymore. Easy way to check that is to flip the switches on and use a test light. Make sure both sides of the fuses are getting power.

MAPWPD
07-12-2010, 04:44 PM
I am confused I used the test light and found no power on the left bag and now no power in two places on the center. What fuse block are you refering too? The one with three plastic covers on it? do you know who makes the switch set up?