PDA

View Full Version : Tower Speakers Buzz when blower is on



jamie_abb
07-12-2010, 10:40 AM
I have my tower speakers run off my amp which is hooked to the sub outlet on my deck. When I have the blower (pumps etc) on, the speakers buzz?

Someone suggested this is a grounding problem?

Brianinpdx
07-15-2010, 05:34 PM
Mike - some decks (like your 700U) have full range sub outputs. He's probably fine. But it does beg the question where did the other 2 sets of outputs go?

-Brian
Exile Audio

brain_rinse
07-15-2010, 06:11 PM
I fixed this issue on mine by grounding the headunit directly to the battery, instead of off the helm bus as it came wired from the factory.

jamie_abb
07-20-2010, 05:37 PM
Going to try ground the unit to the battery. Thanks

jamie_abb
09-06-2010, 06:38 PM
Finally got around to getting the dohickey to wire it to the battery. Fixed the buzz right away.


Thanks
J

brain_rinse
09-06-2010, 06:48 PM
Good deal! Thanks for reporting back. I wonder if SC has fixed this on newer boats...

Brianinpdx
09-06-2010, 07:21 PM
This is a common problem on all boats.

Short answer is just ground to the batteries and be done with it.

Glad to hear it worked out!

Brian
Exile audio

cab13367
09-07-2010, 04:40 PM
I've got the same exact issue so I will try the fix as well and report back. Thanks fellas.

And Mike, on my head unit, I can set the sub pre-outs so that it sends a full range signal.

cab13367
09-13-2010, 12:19 AM
I was getting engine noise thru the speakers, hissing when the blower was on, and a popping sound when I trimmed the wakeplate. I grounded the head unit directly to the battery as suggested here and it fixed all three issues. Thanks!!