PDA

View Full Version : Uhhh yeah...



lewisb13
07-13-2010, 11:11 PM
http://i613.photobucket.com/albums/tt213/lewisb13/New1/IMGP1138.jpg?t=1279073398

clarkro2
07-13-2010, 11:14 PM
http://i613.photobucket.com/albums/tt213/lewisb13/New1/IMGP1138.jpg?t=1279073398

Damn when was the last time you changed the impeller.

lewisb13
07-13-2010, 11:21 PM
HA! I bought the boat on a saturday, took it out that evening at it was fine. 75 hours on the boat. Took it out on sunday and it was HOTTTTTT.....

clarkro2
07-13-2010, 11:36 PM
HA! I bought the boat on a saturday, took it out that evening at it was fine. 75 hours on the boat. Took it out on sunday and it was HOTTTTTT.....


You're supposed to either pull it every year when you stow it or change it every year or two years.

lewisb13
07-14-2010, 12:17 AM
Yeah tell the guy I bought it from that! :D

DOCDRS
07-15-2010, 03:17 PM
how oldis the boat.you can bet the motor oil ,filter,tranny and v drive may not have been serviced either then

deerfield
07-15-2010, 04:17 PM
lewisb13 - Which model boat do you have and where did you find the pieces that broke from the impeller? - Deerfield

lewisb13
07-15-2010, 04:21 PM
All the fluids got changed at the beginning of this season so Im not too worried there. And since the engine was overheating it was putting the boat into "limp" mode to protect the engine which I thought was a cool feature so Im not too worried about having to change the oil since its still honey color. The boat is an 05 LSV. The pieces that I did find were caught in the tube between the trans cooler and the actual impeller. I didnt pull the other end of the tube off and feel around in there with my finger up at the trans cooler, but I will today.

jester
07-15-2010, 10:44 PM
umm for some reason the one on the left look a little wrong. I cannot put my finger on why but it might be a little lop sided.

I hope you found all the parts. You might want to pull the hose that goes from the impeller to the engine and make sure you do not have any hiding out.

gcnettl
07-16-2010, 01:39 AM
I changed mine, original was in. Did not say "Johnson" on it as yours in this picture does. Looks like its been changed before in this case. Did you look at the inside of the impeller housing so make sure everything in there is smooth?
Only time I have really seen one in this shape is when the pickup was clogged with dirt and the engine overheated as no water was making it to the impeller....

lewisb13
07-16-2010, 08:37 AM
I actually pulled it all apart again yesterday. I got a whollllllle other handful of rubber pieces, they were lodged up in that trans cooler or whatever that thing is. I actually called the guy yesterday who was the original owner and he said its never been changed. So thats what it looks like after 76 hours and 5 years. It is recomfirmed because all the paint was still on the little brass bolts and now that I changed the impeller, there isnt any paint left. BTW when I was retorquing all these little bolts, I busted one of them, needless to say there are now stainless bolts in there with lock washers.

kaneboats
07-16-2010, 11:24 AM
Hope you greased 'em good. I think they used the little brass ones to be sure you could get them out.

zegm
07-16-2010, 04:41 PM
I am not quite sure but the picture of the vanes disturbs me. I have had inboards for over 25 years and in the past I went years on these impellers before changing them. What I would see would be that the cylindrical section on the end of the vane would we worn down flat or completely gone. I have never seen one shatter like this with so little hours. I have also had the intake clog up and then actually burned the impeller. But to just have the impeller rip apart into little pieces like that is weird. I am wondering if something got sucked up into the pump and caused this destruction. Has anyone ever changed their impeller after a couple of years and had chunks missing, sort of like an intial stage of destruction?
Final question, on my old skiboat the transmission cooler was before the pump (this is where it got clogged and caused the overheating) now is it after the pump(?), if it is then you really don't have anything to prevent trash from getting into the impeller and possibly causing this issue (and it wouldn't matter when you changed the impeller). Unless you run a strainer like we have on our boat.

csmsk
07-17-2010, 03:19 PM
I'll 2nd that. This is not what a normal thrashed and worn impeller looks like. You should try tennis balls or knotted ropes, as they make much better dog chew toys than a Johnson 812 impeller!!!