PDA

View Full Version : 2010 Ballst switch timer cutting out to quickly



loudsubz
07-14-2010, 05:37 PM
Have a slight issue with the Gravity 3 ballast setup in out 2010 lsv. The switches fill timer will not fill the bags and need to be reset about 3-4 times to completely fill the bag. Sometimes the switch will come close to filling the bag before the fill light will start to flash and turn off the pump, and sometimes it will be pathetic and only fill for about a minute. This happens with all 3 switches and is sporatic at best.

Also on top of the bag I see there is a vent line that goes to a side hull fitting to let water out of the bag, but I never notice any air coming out of this fitting when the bag is filling? If I try and run the bags for awhile to get them really full the bags will feel firm but no air will escape from the vent. Is this meant to only open at a certain PSI to vent or should it be open all the time?

you da man
07-14-2010, 06:20 PM
My vent line has it's own dedicated thru hull fitting so it's open all the time

loudsubz
07-14-2010, 10:08 PM
I have a dedicated vent line for all 3 bags as well, but it seems like they are not open untill under a certain pressure or they are blocked.

jmvotto
07-14-2010, 11:39 PM
is there acheck valve for the vent lines? also. i think ED G posted some timing prgramming fpr the newer ballast systems. did you upgrade your bags at all?

loudsubz
07-15-2010, 10:42 AM
You need to adjust the fill time on your your programmable switches.

I put the instructions in the "how to" forum: "Programming New G3 Ballast"

You will never notice air going out the vent, you probably never get air in the bag.

There is no check valve. It is open all the time. The only thing you will notice going out the vent line is water when the bag is completely full.

If no water is coming out of the vent, you may have a kink somewhere or your line is clogged

There is air in the bags because when I open the third fitting air rushes out and the bag deflates, thats what I have to do for the centre bag allot as I think there is air being pumped into the bag because when I listen to the bag filling it doesn't sound like the rears, it sounds more bubbly.

I will check the how to, thanks

gus 08 mobius lsv
07-15-2010, 11:18 AM
ok i don't wanna jinks myself here but i switch from the factor bags to the 750 lb bags in the rear and i and i didn't reset the timer or add vent lines. i was figuring i'd have to do one or both these things but so far its worked pretty darn good and since i'm not in a big hurry for the bags to fill i just keep the factory set up on the new bags sometimes i'll start surfing till it finishes filling then i'll try to ride the sweet spot but until then i'm just playin around on the big wake. is there something wrong with my timer or switches cause they keep running and i shut it off when it starts spilling water out the thru hull fittings?

wolfeman131
07-15-2010, 12:18 PM
Gus, I don't think the timers were installed until the new system was put in the boats in 2009. Your switches are just on/off.

gus 08 mobius lsv
07-15-2010, 02:00 PM
ah ok thanks for the heads up guys