PDA

View Full Version : Perfect pass question??????



saskyrider
09-07-2010, 06:39 PM
Hello, i was told when i bought my boat that it was prewired for perfect pass. How would i tell.... i'm about to order PP and would like to know what to order...


thanks

geoff

jamie_abb
09-07-2010, 07:56 PM
Don't forget to call PP, most helpful

Paully
09-09-2010, 12:29 AM
Saskyrider,
I had the Stargazer, GPS PP installed in my boat. I think it was plug-n-play. I have toyed around with it and it seems very straight forward. Instructions were detailed but specific. Any issues, and I know they can help you out directly. They helped me when i needed some support for servo cable.

I have a couple pics in my mods of where the GPS receiver is mounted. As well make sure to order the Moomba display face or you will end up with generic.
http://www.perfectpass.com/perfect_pass_products.html
http://www.perfectpass.com/pp_support_usersmanual.html
http://www.perfectpass.com/Perfect_Pass_displays.html

you da man
09-09-2010, 01:00 AM
The plug and play PP is basically the drive-by wire system. Your boat should be drive-by wire but contact PP to make sure. I've heard of guys installing the Stargazer PP for drive-by wire in less than a half hour while the boat was floating on the lake.

Canuckle Head
09-09-2010, 01:54 AM
I bought it for my boat and it was about a 20 minute install. Worth every penny. No more arguments with the wife!

deafgoose
09-09-2010, 02:46 AM
This is first on my list for next season.

Moomba Cruise makes me say bad words.

lewisb13
09-09-2010, 08:51 AM
Yeah I need it really bad too. I cant believe this isnt/wasnt standard on these boats since the early 80s.

saskyrider
09-09-2010, 11:30 AM
I ordered mine from Ian at Only Inboards and he asked me a ton of questions... before putting the order in... i got the moomba faceplate and it should be a plug and play for me as well according to skier's choice, Ian and the guys at PP..

thanks

geoff

jmvotto
09-09-2010, 11:59 AM
This is first on my list for next season.

Moomba Cruise makes me say bad words.

lol. dg i know what you mean

cab13367
09-09-2010, 08:49 PM
"hate to Hijack - anyone out there with PP had major issues with speed control? - specifically 4-7MPH difference with setting to actual?

my buddy's Moomba is having a bit of an issue dialing the PP in - it was installed professionally installed FWIW"

this happens all the time. The non-stargazer units do need to be recalibrated from time to time. Very easy process - requires a gpsr.

I have the wakeboard pro (non gps version) and mine has always worked great. Holds tight to the preset speed and engages properly. At the start of each season, I talke a portable gps with me and check both the speedo and the PP and they usually don't require much, if any, adjustment.

If your friend's PP is varying that much, he needs to adjust the kdw and NN settings. Tell him to download and review the manual from the PP website.

CT Skier
09-13-2010, 04:00 PM
I installed PP Stargazer last year in my '06 Outback. I had Moomba Cruise prior to that. I talked to Gary at PP and we determined that I needed the install kit. It took some time to figure it out (about a day), mostly because I didn't want to mess up my $30,000 ski boat, but looking back at it, it wasn't too bad. There was some minor electrical work I had to do to the ECM module plug ( I needed to add some jacks to the plug that would allow PP to "hijack" the ECM signal so it could tell the ECM what to do), run the cable from the module to the ECM Plug, pull out the old speedo, put in the new one, plug it into the module, and plug in the GPS antenna and speedo wheel. The two hardest parts of the process was working the plug, finding a place to mount the module that would keep it fairly dry, and finding a way to power the system-I ended up hooking it to the old Moomba cruise power wire-for some reason it would only work that way.

Talk to Gary at PP-he'll be able to tell exactly what you need.

Also, for the speed issue, if you're not running it off of GPS, the paddle wheel under the boat may be jammed up, causing inaccurate speed readings. just a thought-my old speedo didn't work at all for the two weeks I got to use my baby this summer.

Sean

deafgoose
09-13-2010, 05:43 PM
I purchased the upgrade kit today to replace the moomba cruise to PP GPS. I got next day delivery so I will be installing it tomorrow. :)

jamie_abb
09-14-2010, 06:48 PM
I purchased the upgrade kit today to replace the moomba cruise to PP GPS. I got next day delivery so I will be installing it tomorrow. :)

Did you buy from PP or only inboards? I've got a wonky dispay so I'm upgrading this year.

deafgoose
09-14-2010, 06:53 PM
Did you buy from PP or only inboards? I've got a wonky dispay so I'm upgrading this year.

Directly from PP because they are in Canada. I received it today but the weather was crap so install day is rescheduled for tomorrow!

viking
09-21-2010, 11:09 PM
I installed PP Stargazer last year in my '06 Outback. I had Moomba Cruise prior to that. I talked to Gary at PP and we determined that I needed the install kit. It took some time to figure it out (about a day), mostly because I didn't want to mess up my $30,000 ski boat, but looking back at it, it wasn't too bad. There was some minor electrical work I had to do to the ECM module plug ( I needed to add some jacks to the plug that would allow PP to "hijack" the ECM signal so it could tell the ECM what to do), run the cable from the module to the ECM Plug, pull out the old speedo, put in the new one, plug it into the module, and plug in the GPS antenna and speedo wheel. The two hardest parts of the process was working the plug, finding a place to mount the module that would keep it fairly dry, and finding a way to power the system-I ended up hooking it to the old Moomba cruise power wire-for some reason it would only work that way.

Talk to Gary at PP-he'll be able to tell exactly what you need.

Also, for the speed issue, if you're not running it off of GPS, the paddle wheel under the boat may be jammed up, causing inaccurate speed readings. just a thought-my old speedo didn't work at all for the two weeks I got to use my baby this summer.

Sean

I don't suppose you took alot of pics of your install along the way did you?
Would be a good "sticky"