PDA

View Full Version : Several issues...new boat....please help...



pig140
09-08-2010, 10:35 PM
I bought my 2010 Moomba LSV about a month ago. I've had numerous tournament boats - but this is my first boat this new. I've had several issues that I'll have addressed when I take it for its first service, but I was curious if anybody could advise me on a couple of these. Maybe you've had a similar issue or can tell me if this is normal. Besides other obvious warranty issues, I wanted to ask you guys about the following problems:

1. My tower is powdercoated black. The powdercoating is peeling out and flaking off in chunks inside the letters "MOOMBA" on the cross piece. Anybody else's do this? Anybody just pull the letters out and leave it "MOOMBA" silver?

2. The front ball/socket arms on my Z-5 cargo top slide in and out. There are 2 bolts with lock nuts on each one. I assume the dealer was supposes to adjust or tighten these? Or I am? Or are they to remain loose?

3. All my bag valves leak a tiny bit? One of the pro shop guys told me this was normal. Is it?

4. Major stereo issues (all warranty) - transom control has condensation. Since the condensation - which won't drain, the radio is acting crazy. No control over it, shows all kinds of symbols. We have to keep it off. Anybody else have something like this?

I bought it a dealership 5 hours away, but I'll be taking it for service to a closer dealership. I did call the dealer and talk to him about it some of this and I know its warranty, but I was curious if any of you could give me advice on at least the Z-5 top adjustment.

brain_rinse
09-08-2010, 11:28 PM
Welcome to the forum! Sounds like typical new boat bugs to me. Not fun, but nothing major. No experience with your questions 1 and 4 but...

2. They should be tight. Just center the top and snug them up.
3. On a 2010 you'd have reversible jabsco pumps, so not sure what you mean by valves. The pumps?

pig140
09-09-2010, 04:14 AM
Thanks for the welcome! I was hoping maybe it was that I'd just have to tweak a little because it's new. They makes me feel alot better.

Thanks for the help on the Z-5, I'll do exactly what you suggested.

I used the wrong word when I said valves. I should've said seals. They all drip where the hose is connected to the plastic piece that screws on the bag. Looks like some white sealant was used, but it still leaks a tiny bit.

mmandley
09-09-2010, 10:34 AM
The small leaks are really not an issue, unless it really bothers you then you can reseal it.

As for the transom remote they didnt start using that brand till 2010 so its all pretty new, you should be able to reach up behind the deck and there is a remote wire you can unplug. This doesnt fix the issue by will allow you to enjoy the tunes till you get it fixed.

gcnettl
09-11-2010, 09:43 PM
I am guessing that the dealer had the powder coat put on as an option. Only thing you can do is get him to make good on it. As my rule, I do not buy anything with an aftermarket powder coat.

kaneboats
09-13-2010, 10:04 AM
If you ask me (and I know you didn't) "powdercoating" is the biggest scam going. It's just paint and it flakes off like paint.

dru1974
09-13-2010, 12:40 PM
have a new 2010 aswell and i am wondering if these dealers are painting these towers. min isnt painted nore would i do that. looks great brushed aluminum in my opinion i didnt get the transom remote when i ordered mine......but as far as the seals leaking a bit, mine do awell but it really doesn't bother me.I would suggest that the transome remote isn't quite sealed enough. maybe you should ask if they can put an un "powdercoated tower" on your boat.

Good luck!

deafgoose
09-13-2010, 12:51 PM
You can use teflon tape, clear silicone or even PVC glue to seal up the fittings that screw into your ballast bags to seal them up.

viking
09-13-2010, 01:04 PM
I beleive SC used all purpose PVC cement when they put them in as dealer ordered options - unless they've changed that?

It keeps them sealed but kinda a PITA to get them out if you ever need to! My new bags I just screwed the fittings in hand-tight and don't seem to leak yet!

pig140
09-13-2010, 06:39 PM
Thanks for the responses. The dealer said they ordered the tower black. Wherever the anchor light got installed (and this is another aggravating issue), whoever ran the wiring scrached the powdercoat about 3 inches when they drilled the hole. So it got powdercoated before having that installed. I'm pretty sure I can cover the scratch with a little automotive touch up paint.

I took it this weekend to a closer dealership for its first service and they said they believed the factory powdercoated it but forgot to pull the coating out of the letters - making the tower black with "MOOMBA" in silver.

I asked about the seals and was told that they shouldn't leak, I did notice the light PVC cement around them.

He also said he thought the radio was acting so crazy because of the transom remote. I wish I had unplugged that remote and tested the radio before dropping it off just for my own peace of mind. Its warranty either way tho.