PDA

View Full Version : Overheating / Wet Exhaust hole



JKizerb
09-14-2010, 02:00 PM
Ok, noob here and prob will get a lot of criticism. 03 moomba outback ls, first season owning it.

But took the boat out this weekend and noticed a burning smell coming from the back while i was skiing/wife driving. She didn't notice the temp rising and when i finally climbed in the boat boat, the wet exhaust hoses had holes in them and no water was passing through the manifolds.

Pulled the impeller, its shot and started cleaning debris, and a new one is on order. Same for the exhaust, but figured I could just slide the wet exhaust hose right off, but man is it stuck on (melted?). ANY ideas on simple removal of the exhaust?

Any other musts I should do to check would be greatly appreciated

Jeremy

kaneboats
09-14-2010, 04:10 PM
Sorry, don't have any ideas for you. Sounds like you are going to be doing some scraping.

zabooda
09-14-2010, 05:45 PM
You are very lucky if all you have is an impeller and exhaust tubing replacement. Try to remove all of the impeller fragments.

viking
09-14-2010, 10:17 PM
I had a similar issue with my 90 supra comp. Impeller got chewed up and started to overheat. Ended up melting one of the exhaust hoses as well. Got them both replaced and ran like a SC should again :) Good luck!

DOCDRS
09-16-2010, 09:29 PM
use a torch and heat up the hose....will soften it and make it easier to remove

JKizerb
09-20-2010, 12:16 PM
The new tubing arrived and it seems a lot easier to bend/move. Torch sounds like a good idea. Thanks everyone