PDA

View Full Version : Help! Lost Power to Fuel Pump



zlloyd1
09-23-2010, 11:42 PM
I have a 2005 Mobius LS, this is my first boat so I am new to all the maintenance required, but am fairly handy with mechanical and electrical stuff and prefer to try most stuff on my on. I have lost power to the fuel pump, and have temporarily wired it off of the battery with a switch to get me back on the water while trying to pinpoint the problem. The Owners manual says there is a fuse for the fuel pump on the back of the motor but either I am missing it completely or it isnt there.Any help or ideas on what to look for would be greatly appreciated(Pictures welcome).
P.S. Been a part of the Moomba family since the beginning of July and have had blast so far,tons of compliments on the Mobius from friends and strangers. No Worries.:cool:

T100
09-27-2010, 02:31 PM
Same happened to me, search Oil Pressure Switch, its to the left of your distributer cap three wire.

lewisb13
09-27-2010, 02:37 PM
He doesnt have a distributor. At least my 05 is electronic ignition.

NCSUmoomba
09-29-2010, 08:46 PM
I have lost power to my fuel pump a few times when I drove a double up and the lead got knocked off the ignition switch. Simple fix for me. Have you checked there?

zlloyd1
10-01-2010, 02:34 PM
I have not checked the ignition switch lead yet, boat ran fine with my "rigged" setup last weekend, so I will do some more investigating this weekend.

rc5695
11-03-2010, 03:37 PM
I have not checked the ignition switch lead yet, boat ran fine with my "rigged" setup last weekend, so I will do some more investigating this weekend.

any luck? appears I'm having a similar problem...