PDA

View Full Version : Boat dies on fake-a-lake?!?!?



rc5695
11-02-2010, 01:17 PM
Boat ran PERFECT all year. FLAWLESS!!! It has been sitting for a couple months, and I was getting ready to winterize it and started it up to warm it up...

Ran for about 45 seconds and just kinda died out. Wouldn't re-start... Noticed gas guage was WAY low, and the boat was at a funky angle in the driveway, so I dismissed it and figured I'd fill it up for the winter and then mess with it later.

I filled it with gas a few days later, and the same thing happened!!! :confused: Fired up perfect, ran great, and then sputtered out. I checked my fuel pump, and NO POWER!

Any ideas what would cause my '00 Kamberra with the 350 Chevy to quit sending power to the fuel pump after ~ 1 minute of operation???

I replaced the fuel filter/water seperator just to make sure it wasn't plugged or something...That's all I've done, and that was after it died the 2nd time...

Please help :(

T100
11-02-2010, 03:58 PM
Don't know if you have one but check your Oil Pressure Switch, it supplies power to your fuel pump. Search "Oil Pressure Switch" on the search engine of this site.

rc5695
11-03-2010, 03:34 PM
Don't know if you have one but check your Oil Pressure Switch, it supplies power to your fuel pump. Search "Oil Pressure Switch" on the search engine of this site.

Will do. Thanks!

rc5695
11-08-2010, 01:51 PM
that stupid oil pressure switch is only $10 @ O'Reilly's, but nobody in town at any auto parts store has them in stock :( Seems that it hasn't been used on a car since around the '70's?

p/n is S352 for a BWD Oil Pressure Switch Advance Auto & O'Rielly's, other stores can cross-reference. Still waiting on OReilly's... (11/12/10)...And now I've gotta work this weekend :(

rc5695
11-15-2010, 01:05 PM
Thank you SSOO much T100 and this site! A silly $10 switch caused that much headache; who knows how much it would've cost if I'd have taking it somewhere! Running perfect again.

Got it winterized & oil changed yesterday. Now, who's ready for spring??? ;)

deerfield
11-15-2010, 02:16 PM
T - Nice assist! - Deerfield

T100
11-15-2010, 07:13 PM
Glad to have helped, that is why this site is so great, guys helping each other out that have to fix it in a pinch. Canuklehead helped me this summer (via Blackberry) on the same issue while I was out at my cabin on holidays and it was two weeks to get into my local boat shop.
Happy boating