PDA

View Full Version : Hello From South Africa Need Help



vaalguy
11-15-2010, 02:38 PM
Hi there guys

I am brand new to the forum, i come from sunny SA and i am the new proud owner of a supra Launch 20ssv yes yes i know its a supra but hey there is much more activity here.

i need help with three things

1. something is wrong with my ballast, they fill up 1/4 then the button on the gravity ballast flashes twice?

2. how do you work the stadium seating?

3. when put in reverse gear my boat make a high pitched sound like a belt slipping the dealer said that it is normal, is it?

thanks for your help guys

moombadaze
11-15-2010, 06:43 PM
Welcome to the forums


my answers

1) timers need set-think you have a 09 or newer, otherwise no idea

2) no idea as Ive never been in a supra with that seating

3)sounds normal- vdrive or trans gear noise-same on my lsv

hope it helps and post a photo for us if you can

cab13367
11-15-2010, 07:19 PM
Hi there guys

I am brand new to the forum, i come from sunny SA and i am the new proud owner of a supra Launch 20ssv yes yes i know its a supra but hey there is much more activity here.

i need help with three things

1. something is wrong with my ballast, they fill up 1/4 then the button on the gravity ballast flashes twice?

2. how do you work the stadium seating?

3. when put in reverse gear my boat make a high pitched sound like a belt slipping the dealer said that it is normal, is it?

thanks for your help guys

1. Like daze says, you must have the new ballast system with the reversible pumps. They are on a timer so that they shut off after a certain time. You need to reprogram the timer (instructions are on this site somewhere) or turn the switch off and then on again to reset the timer.

2. If it's the same as the LSV, just pull the rear center cushion towards the bow and viola!, stadium seating.

3. Mine does the same exact thing and was also told it's normal.

Welcome to the forum and congrats on the new boat!

DOCDRS
11-15-2010, 07:46 PM
Hi there guys

I am brand new to the forum, i come from sunny SA and i am the new proud owner of a supra Launch 20ssv yes yes i know its a supra but hey there is much more activity here.

i need help with three things

1. something is wrong with my ballast, they fill up 1/4 then the button on the gravity ballast flashes twice?

2. how do you work the stadium seating?

3. when put in reverse gear my boat make a high pitched sound like a belt slipping the dealer said that it is normal, is it?

thanks for your help guys


1. here is how to http://moomba.com/msgboard/showthread.php?t=11192


2. already covered by cab

3. its normal to have a high pitch whine, its the transmission, I agree with daze and cab

DOCDRS
11-15-2010, 07:57 PM
ok guys apparently he has an 08 ssv so its old school ballast, I cant help

sandm
11-15-2010, 08:21 PM
I can only answer #2 for sure- take seatbottom off that's over the tranny. pull the pass side seatbase out in the center of the boat. there's 2 angled chrome bars, place them in the brackets sticking straight up. slide center seatbase you took off from over the tranny down the bars and that forms the seatback. it really makes sense if you grab the pass. center seatbase and swing it out into the center of the boat. you will see it :)

mine has a whine in reverse as well. figured it's just the tranny/vdrive going the opposite direction. not real bad, but there. gets louder the faster you go in reverse. have 300hrs on the boat and been doing it since day one. dealer here says it's normal too..

#1 might be a short in the wiring. there's no timers to worry about. check connections behind the panel and at the valves would be first step.

good luck...

vaalguy
11-16-2010, 07:31 AM
hey thanks gents this has been a real help,

hoe do i post a pic on here do i have to use a third party site to upload to?

vaalguy
11-16-2010, 07:35 AM
here is my boat parked at my jetty,

sorry its an 09 model im really chuffed with it, the market is pretty monopolised here and the local boats are really badly made. but on the other hand cheap.

you could get a 18ft with a 200hp engine for about R180 000 here not sure what the exchange is,

so this is my first proper boat:p

vaalguy
11-16-2010, 07:47 AM
Hey guys here are some more pics of my boat and spot on the river,

the guy driving in the one pic is my business partner,

also i must say im enjoying this forum the wealth of info on here is uncanny.

enjoy the pics will get some more up soon

wakeskating etc

vaalguy
11-16-2010, 07:53 AM
I can only answer #2 for sure- take seatbottom off that's over the tranny. pull the pass side seatbase out in the center of the boat. there's 2 angled chrome bars, place them in the brackets sticking straight up. slide center seatbase you took off from over the tranny down the bars and that forms the seatback. it really makes sense if you grab the pass. center seatbase and swing it out into the center of the boat. you will see it :)

mine has a whine in reverse as well. figured it's just the tranny/vdrive going the opposite direction. not real bad, but there. gets louder the faster you go in reverse. have 300hrs on the boat and been doing it since day one. dealer here says it's normal too..

#1 might be a short in the wiring. there's no timers to worry about. check connections behind the panel and at the valves would be first step.

good luck...

haha i still dont really understand as i think i need to be in the boat when reading this, but damn i fell stupid i have been tugging at the port side seat thinking that maybe the longer i pull it it will eventually magically turn into a stadium seat haha

MartinCaron
11-16-2010, 12:45 PM
R180 000 = 25774 Usd

Those waters must be full of dangerous creatures ???

vaalguy
11-16-2010, 01:08 PM
ballast switch flasing 2 times is definetly a sign you need to re-calibrate your timers.

I posted the instructions in the "how to" forum.

thanks very much i will try it seems seriously complicated but ill see how it goes

badasshybrid
11-18-2010, 09:03 PM
Nice area you live at there, Sharp boat as well. I cant help you on the seats or ballast. But my boat wines in R too.

DOCDRS
11-18-2010, 09:47 PM
thanks very much i will try it seems seriously complicated but ill see how it goes

its really not that complicated, reprogrammed for my 1100's with out a prob

lsvboombox
11-18-2010, 10:17 PM
its really not that complicated, reprogrammed for my 1100's with out a prob

how long should they run for the 1100's? i just upgraded.....

DOCDRS
11-19-2010, 02:05 PM
how long should they run for the 1100's? i just upgraded.....

I have mine set for 9 mins then top up manually with the add 30 or 60 seconds switch