PDA

View Full Version : Tow Rig Upgrades



walb0244
01-07-2011, 08:38 PM
http://sphotos.ak.fbcdn.net/hphotos-ak-snc6/hs079.snc6/168988_1523275003715_1289804021_31241111_6484323_n .jpg

Not the greatest picture of it yet but it was one of the first. Camera battery dead so more pictures will have to wait. Got a few pics of it on top of a rock pile but the pictures didn't turn out too good. The paint job has been on there for the past 4 years. The lift kit, rims, and tires are all brand new.

skiyaker
01-07-2011, 08:51 PM
nice rig. I'll recognize it for sure if I see it at the ramp! Did you ever make it to Brookville last summer?

walb0244
01-07-2011, 09:03 PM
I never did make it up there. Something came up that weekend that too priority. Hopefully this year tho I would really like to get out and meet alot of people that are also boat lovers. Also, would like to get a chance to ride in some other moomba and maybe get someone to ride in mine. Every so often at the end of last season my boat got to where it was starting to make a little vibration every so often that would only last a about 5 seconds and then would stop. i never could figure out what it was tho. Will be chaning all the fluids before taking it out this summer so hopefully that might take care of it. You could feel the vibration on the floor over the gas tank near the back seat. So thinking maybe tranny or vdrive but hoping not either.

skiyaker
01-07-2011, 09:51 PM
well drop me a line anytime you're down there next summer. my pops has a cabin up in the woods close to Brookville so I'm at that lake all the time. My neighbor has a 24 ft supra and he'll bring it down there so we could ride from smallest boat to largest. Templeton Creek is the "party cove" and there's a nice campground there. Your truck will get more attention than you want especially when hooked up to your LSV!

Ian Brantford
01-07-2011, 09:59 PM
Every so often at the end of last season my boat got to where it was starting to make a little vibration every so often that would only last a about 5 seconds and then would stop. i never could figure out what it was tho. Will be chaning all the fluids before taking it out this summer so hopefully that might take care of it.


This could indicate a propeller shaft packing issue. Tightening or replacing it might help.

jmb
01-08-2011, 03:09 PM
Also could be shaft alignment. Just had mine checked