PDA

View Full Version : Boat died



dess03
04-09-2011, 12:55 PM
lets see if you guys have any ideas 03 mobius lsv
we were at the end of the day tubing and the display for the perfect pass went out kinda went crap that sucks about 15 mins later it come back on then shortly after that the boat just dies all the gauges styaed in the position thaty were in speed rps all of it the boat wont even turn over but anything that runs off a toggle still works radio ballast any ideas this is really got me worried it could be major

Moseley618
04-09-2011, 12:56 PM
Kill Switch?

dess03
04-09-2011, 01:03 PM
dont have a kill switch

Moseley618
04-09-2011, 02:10 PM
You don't have a kill switch with a lanyard attached right under the throttle? I have one on my 04 LSV.

harmsway
04-09-2011, 10:43 PM
If you have a breaker switch coming off your positive battery cable it may have tripped. There is a small reset switch on the breaker make sure it is in the correct position. If the breaker isn't tripped get the volt meter out and test the wires coming of the ignition switch. You may find one of these have come loose.

FLTH2O
04-10-2011, 01:21 AM
lets see if you guys have any ideas 03 mobius lsv
we were at the end of the day tubing and the display for the perfect pass went out kinda went crap that sucks about 15 mins later it come back on then shortly after that the boat just dies all the gauges styaed in the position thaty were in speed rps all of it the boat wont even turn over but anything that runs off a toggle still works radio ballast any ideas this is really got me worried it could be major

Check your wire connections on the ignition switch, wire connections on the power bar under the dash and the connections around the battery.

NCSUmoomba
04-10-2011, 11:07 AM
Yep, my vote is for a wire on the ignigtion switch came loose and then fell off. I have had that happen to me a couple of times driving double ups.

And yes, not all our boat have kill switches. My 2001 Outback does not have one.

DOCDRS
04-10-2011, 02:19 PM
Yep, my vote is for a wire on the ignigtion switch came loose and then fell off. I have had that happen to me a couple of times driving double ups.

And yes, not all our boat have kill switches. My 2001 Outback does not have one.

Yes I have had wires come loose, off as well.....stereo died once and finally traced it back to a lead on the stereo power switch, once to a power connector union......things come loose with all the pounding

dess03
04-10-2011, 04:11 PM
tried putting a new battery in and the wires on the back of the ignition switch were still on im gonna go out with my multimeter and check to see if its not the switch itself that hasn't gone bad