PDA

View Full Version : wakeplate not working well



LyndonH Dubai
04-11-2011, 05:09 AM
hi
my wakeplate seems to not go the full way down to enable the boat to plane properly. my mechanic (who has now left the country) told me i may need to top up some hydraulic fluid, but I simply cannot find where to do this?also what fluid would i need to top it up with? any other ideas (it stays up fine but boat rides to high)
i have the 2004 XLV
thanks for all your help again (im getting all my threads out today in one go as I really want my boat sorted now!):confused:

brain_rinse
04-11-2011, 11:01 AM
How far down does the plate go?

You should be able to trace the lines back from the wakeplate actuators to find the hydraulic fluid reservior. If you're low on fluid you most likely have another issue like a damaged actuator or loose fitting. Have you noticed oil in the bilge?

VA LSV
04-11-2011, 12:22 PM
Also check for leaks at the cylinders. Fluid is standard ATF.

squeeg333
04-12-2011, 05:19 PM
Check your connects the steering wheel. The wires that come from the actuator that go into the switch on the steering wheel. These come loose, and contact is lost. I've had this happen several times from messing around with the steering wheel. Easy fix, and even easier to check. Typically the yellow wire is the one that gives me fits.

brain_rinse
04-12-2011, 05:44 PM
Check your connects the steering wheel. The wires that come from the actuator that go into the switch on the steering wheel. These come loose, and contact is lost. I've had this happen several times from messing around with the steering wheel. Easy fix, and even easier to check. Typically the yellow wire is the one that gives me fits.
Same here.