PDA

View Full Version : New Moomba owner - Questions



pasbrittcote
05-01-2011, 09:42 AM
Hey guys,

Just got my new boat: 2005 Mobius LSV. It was my first run yesterday and I have a few questions for you guys.

- Any way I can lubricate or do something as I find the steering wheel hard to turn? Everything works but I was expecting the driving - turning would have been easier...

- What should be the normal operating temperature? Yesterday the gauge was showing 180. Thought this was a bit high but maybe i am wrong. I will change the impeller before my next ride to see the difference....

- one last question regarding the ballast... The left rear ballast will fill out quickly but won't drain even with switch on... Any advices? Everything is correctly connected but I don't hear the pump when i flip the switch to empty the ballast...


Many thanks! :lol:

harmsway
05-01-2011, 10:12 AM
- Any way I can lubricate or do something as I find the steering wheel hard to turn? Everything works but I was expecting the driving - turning would have been easier...
You can do a search on "lubricating steering cables" in the forum. A few people have drilled holes in the steering cable casing and was able to free the cable back up. The best way is to replace the cable and there is some threads also on that if you do a search.


- What should be the normal operating temperature? Yesterday the gauge was showing 180. Thought this was a bit high but maybe i am wrong. I will change the impeller before my next ride to see the difference....
180 is the correct operating temperature. Mine usually runs 170-185 just depending on lake water temperature.



- one last question regarding the ballast... The left rear ballast will fill out quickly but won't drain even with switch on... Any advices? Everything is correctly connected but I don't hear the pump when i flip the switch to empty the ballast...
You need to make sure you are getting 12v to the (empting) ballast pump itself, if you are then the pump is probably bad, and alot of the pumps during those years were basic sump pumps that are available at most places that sell boating supplies. "even walmart carries some"

Razzman
05-01-2011, 10:26 AM
I can't remember for sure but I believe there's seperate fuses for fill and drain. Look up under the dash and you should find a small fuse block.

180 is normal operating temp.

pasbrittcote
05-01-2011, 07:20 PM
Thanks guys for your help!