PDA

View Full Version : XLV bilge design flaw, poor drainage



Steve23
02-20-2005, 06:37 PM
On my 2004 XLV the lowest part of the bilge is lower than the bilge pump pick up and also lower than the bilge drain on the transom. With this problem there is always a few inches of water in the bilge that won't drain and can't be pumped out. At best this water winds up as a breeding spot for mosquitos and smells bad, at worst I'm worried this water could cause problems with the fiberglass in the bilge area over time. My local dealer said Skiers Choice was aware of the problem but I haven't heard if there is a fix available. Jacking up the trailer all the way doesn't help either.

Thanks for any information
Steve

Aquaholic
02-20-2005, 07:16 PM
I hope that SC replies with a possibe solution. But can you move the bilge to a lower point?? I have an 05 XLV and it's brand new and the other day during the break in I had to "tap" on the top of the bilge pump to get it to turn off. I thought I had the switch in the wrong postion at first but the tap did it. Any way.........

Aquaholic

Steve23
02-24-2005, 09:03 PM
I'm hoping that Moomba/SC does have a kit to relocate the bilge pump to the low spot. I'll be taking my boat in next month for de-winterization and I ask then. Can you tell on your 05 XLV if there is standing water in the bilge after it is drained and pumped out? On mine it's more to the back under the motor, the kind of thing you wouldn't notice unless you really checked that the bilge area did drain completely.

Steve