PDA

View Full Version : Vapor lock solutions? Engine Nut? Suggestions? Diagnosis?



volfo
05-31-2011, 12:36 AM
I have 2001 OB LS with Indmar throttle body fuel injection 320 hp. Engine is exhibiting this behavior: runs perfect until it runs for quite awhile, and then shuts down for quite awhile, on hot days. Then it will start, race, try to run for about 30 seconds to a minute, then die. Then start right up, run about 10 seconds, then die. Then it basically will run about 2 seconds and die until it cools off a bit, in which case I can maybe get it to run 30 seconds or so before it dies.

Stranded on lake for second time in last few trips. First time was on super hot day last July where we played all day, then stopped and swam in a secluded cove for about an hour and a half. Did exactly as above. Changed fuel filter, checked fuel pump, everything fine, wouldn't start even the next day. Took it in to shop. They looked at it 3 days later, said it started first turn and ran like a champ. Had some routine maintenance done. Then today, super hot, running all morning, stop at marina for lunch. Come back out about 1 hr and 15 minutes later, same thing. Towed all the way home. Any suggestions?

Please note I have no trouble at all if I just shut off the boat for 2-10 minutes or so such as to change skiers, take a quick dip, etc. But if boat is off on a hot day after running earlier for a prolonged period of time, it struggles to start. Once or twice in this time it has raced on start-up but powered through it and once going run fine. But twice now I"m stranded. Mechanic suggested changing from 3/8th inch fuel line between pump and filter to 1/2 inch and insulating. If that doesn't work, try a new fuel pump. Any thoughts? Much appreciated.