PDA

View Full Version : Perfect Pass Computer Module Story



myster
06-14-2011, 01:20 PM
Hi All.....Well, my perfect pass module wouldn't turn on this year after two trouble free years. I contacted PP about it and they were quite willing to have me ship it there for repair for a very modest $50 charge. I found out a few things along the way..ie apparently some Moomba's have a VERY high start up voltage which can fry the control board!! Anyhow, I started cc'ing the Dealer ( Bay Marine in Belleville ont ), and Skier's Choice on my email adventure. Both responded VERY quickly, and Bay Marine provided their usual excellent Customer Service. Bottom line, PP decided to replace the Computer Module ($300) free of charge and it has now been shipped. I believe that this was the right thing for them to do, but yunno, it doesn't always work that way. In the end I am happy with my dealings with all three companies!!!

bludpumper
06-14-2011, 01:48 PM
My experience with the PP guys has been the same. Top notch service.

lsvboombox
06-14-2011, 02:20 PM
have they done anything to the boards to prevent the boards from frying? or will it just happen again eventually?

myster
06-14-2011, 02:47 PM
Of that I'm not 100% sure. They were up to series 3 on those boards, and I'm hoping they have a series 4 now:rolleyes: ......LOL, I would think they would "beef" it up a bit to handle a higher start up voltage!!!!!

loudsubz
06-14-2011, 09:33 PM
Bay Marine is great. It is over 2 hrs away but we bought our '10 LSV from them because of their customer service.

They go out of their way to help and always respond to emails.

Mikey
06-14-2011, 10:01 PM
Supposedly PP has refigured out the control modules as i burned mine up while on holidays ,in Idaho. They sent one to the cabin i was staying at UPS the next day,Plugged it in and poof ,burned another one, Called them,and next day again i was sent another and sent one back. Since then all is good.
Nice service i must admit. Lost 3 days ,not 2 weeks like i was expecting. Awesome customer service.

Supposedly a couple years were the only ones affected and i believe problem solved just need to get the correct model for the boat year and model etc and you should be good to go.

myster
06-15-2011, 09:12 AM
This is all good guys, but now Canada Post has "locked out" their employees, so unless they sent it to me by some other means, I think I'm probably F**cked!!!!!!!! at least for a while anyway

loudsubz
06-15-2011, 09:32 AM
Me2. I have a repair kit coming for a wakesurf board via CP....

myster
06-15-2011, 01:01 PM
I'm in Luck........ Fed Ex air from Dartmouth to Bay Marine, and Purolator after that....should have it by Friday with any luck:D

Shooter
06-16-2011, 12:39 AM
How did they act with the board fried? Mine is giving me fits right now. It will run at 22.2 mph regardless of the setspeed when in wakeboard mode and runs a steady 4mph slow in slalom mode.