PDA

View Full Version : Finally got it in my Carport.



Will Watters
04-12-2005, 11:35 AM
I finally picked up my LSV on Saturday and dropped it in the water for break-in on Sunday. Spent the day motoring the length of Lake Washington, and Lake Union, got 5 hours of running and hope to be ready to tow this weekend (weather permitting, still a little cool) No problems fluid levels checked good, however, I did note that the tranny screw on dip was secured only about a half turn. Looks like the dealer got a little quick during the pre delivery check. I will look at this to make sure it is not back out on its own.

Two questions:

Who out there use the little lockout lever when backing to launch; or do you keep the electrical connector on? The trailer lights are sealed, so I chose to keep the electrical connection. The little lock out key appears to be subject to failling out....

One more thing, who out there removes the plug after each use? I did this on my old boat, but not sure if I need to on the LSV. I think I will unplug periodically at home and then re-attach but keep it in during trailering to/from water.

Will

james yarosz
04-12-2005, 05:42 PM
I never unhook the lighting plug,but I always remove the drain plug when trailering.It seems the only wat to get ALL the water out of the boat.I tape the plug to the steering wheel.Haven't forgot to put it back in yet.

NC05LSV
04-12-2005, 06:40 PM
One thing that I have noticed about the LSV and XLV is that they retain water in the bilge. The only way I have been able to fully empty my boat is to pull it just out of the water and remove the plug while still on the ramp before pulling forward. sometimes people get a little ansy at me taking extra time but they get over it. I have always just left my trailer hooked up and have never used the over ride. I have had no problems (knock on wood).