PDA

View Full Version : fuses for the stock stereo



jmvotto
07-21-2011, 09:09 AM
yesterday the oem plug for the stereo. power negative and remote was loose and was cutting out. so i decided to remove the plug al together. after i put the matching wires back. i got nothing. dead. so i think i blew a fuse. the loom runs around the bow. any idea where the fuse could be.:confused:

cab13367
07-21-2011, 10:18 AM
yesterday the oem plug for the stereo. power negative and remote was loose and was cutting out. so i decided to remove the plug al together. after i put the matching wires back. i got nothing. dead. so i think i blew a fuse. the loom runs around the bow. any idea where the fuse could be.:confused:

Did you check the back of the head unit?

jmvotto
07-21-2011, 10:51 AM
not yet. i will. so i assume no in line fuse along that loom.

thanks al.

vacation with no stereo equals no fun.

spent the day out on my buddies x45 yesterday. what a machine. pics to follow.

cab13367
07-21-2011, 11:09 AM
not yet. i will. so i assume no in line fuse along that loom.

thanks al.

vacation with no stereo equals no fun.

spent the day out on my buddies x45 yesterday. what a machine. pics to follow.

I faintly remember that it has an outboard fuse like amps do. If there is an inline fuse, it should be pretty close to the wiring harness.

How is the surf wake behind the X45? My brother is disappointed in the surf wake behind his X25. He can't get it to clean up no matter what he does. He is very envious of my surf wave :)

jmvotto
07-21-2011, 01:32 PM
Fuse is fine on the unit. No sign of an in line fuse. Unit maybe toast. I will have to get a multi meter to test the wires. Red yellow black. May find someone to overnight one. Or I can rewire the power to the ws420 and use the input..

X45 surfwave is decent but he got the extra plug n play option on top of the hard tanks. Surf tabs help as well.

jmvotto
07-21-2011, 11:29 PM
found it. in line 10 amp fuse right above the bus panel under the helm. tough to get at with the heater tube install.

wolfeman131
07-21-2011, 11:33 PM
how many beers did that take?

enjoy the vacation at the lake!

jmvotto
07-21-2011, 11:39 PM
more than i would have liked. it hit 100 here today. holy hot batman.:p

vacation is great. got my 10 year old upboarding second try. and the older ones 13 yr old trying some wake jumps and riding switch.

wolfeman131
07-21-2011, 11:43 PM
yep. that sounds like a great vacation!

be safe, have fun and enjoy.

cab13367
07-22-2011, 01:04 AM
found it. in line 10 amp fuse right above the bus panel under the helm. tough to get at with the heater tube install.

Wow, I would never have guessed it would be over there. Sorry, missed that one.

cab13367
07-22-2011, 01:04 AM
vacation is great. got my 10 year old upboarding second try. and the older ones 13 yr old trying some wake jumps and riding switch.

Nice! Sounds like a great vacation so far.