PDA

View Full Version : Starting Issues (And now Boat wont Start!)



royalchez
08-30-2011, 07:28 PM
Guys, I need some help! So here is the issue I'm having some major issues with my 06 Mobius (Carb). It started off a few weeks back and the boat was not starting initially when launching it. It took a few times, a little primer, and finally the boat would start. Once it started, the boat ran just fine, idled a little bit rough at first, but after about 2 mins it ran fine all day. This problem has progressively gotten worse now. I played around with a few mentions that I got from this forum (Fuel Pump, Safety Lanyard, Battery, Vapor Lock) And I cannot pinpoint the problem. We thought we had it figured the other day when it was an improper grounding of the fuel pump, but as it turned out that wasnt the case. Then I figured maybe a battery issue, so I flipped the switch for my fuse kill and left it until I hit the boat launch yesterday. The boat started on the first attempt no problem, and ran all afternoon, turning it off and on at least a half dozen times. Then after sitting for about 20 minutes, went to fire it back on and nothing. Couldnt get it to go whatsoever and had to get towed back to the boat launch. I am at my whits end here and have kind of maxed out my limited mechanical knowledge. Worst part being is that the local boat dealers cant do anything till about Sept 20, and up here in BC Canada, that pretty much ends my boating season. There seems to be some fuel going into the carb, especially when I put the boat in neutral and bury the throttle, you can see the fuel dump in. Im thinking its got to be something electronically that is not getting the fuel to the engine as I am pretty sure the fuel pump is fine, as we can see some fuel and it occcasionally floods. Any help would be greatly appreciated!