PDA

View Full Version : Speedometer not working



Yellowmobius
05-11-2005, 04:32 PM
Where do you start? is it the wheel or the gauge.

What does it cost to replace the paddle wheel and cable?

2001Mobius

WakeMe
05-11-2005, 05:18 PM
Is it just one speedo not working? The paddlewheel is about $15. That is for just the little paddlewheel and the shaft that it rides on. That will fix it some of the time.

Yellowmobius
05-11-2005, 05:19 PM
Just the one speedo. I think it is more like the sensor and wheel that is bad

WakeMe
05-11-2005, 05:25 PM
Well you can take the wheel out the one that is working and put it in the one that is not and see if that fixes the problem. Then you should know if it is the paddlewheel itself. If you tow your boat long distances and don't put tape over the paddlewheel it can burn it out from spinning with no water to lubricate it.

lowdrag
05-11-2005, 08:37 PM
Correct me if I'm wrong, but I think there is only one sensor and paddlewheel in the hull of the boat that runs both speedos. If that's the case, it sounds like a problem with a loose wire or something wrong with just the one speedo.

Yellowmobius
05-11-2005, 09:51 PM
My boat has two at the rear of the boat.

05-11-2005, 11:40 PM
I believe they made the switch in 2002. Thats when they went to the single midship paddlewheel. Be sure to let us know what you find out.

WakeMe
05-11-2005, 11:47 PM
I believe they made the switch in 2002. Thats when they went to the single midship paddlewheel. Be sure to let us know what you come up with Bruce.

lowdrag
05-12-2005, 07:00 PM
That would explain it, mine's an '03. Thanks.