PDA

View Full Version : Winshield Removal



iwaterskihard
04-13-2012, 12:32 AM
I have searched this forum for anyone who may have removed or replaced their winshields on their boats without very much success? That said I see lots of people have had their boats into service shops or replaced all or parts of their windshields with lexican glass.

What I'm searching for is - has anyone removed and either replaced or repaired their winshields themselves? My walk-through window is seperating at the top and really starting to p*ss me off.

I did talk to Rick T and he said I should take it into my closest dealer and have them look at it. I'm not that close and have a plan in mind by maybe taking it off and wedging it somehow.

I currently use a ratchet strap to sqeeze the upright supports somewhat tight (real snug) then close the middle window prior to any travel or trailering of the boat.

Anyone out there done anything like this and can you offer me some advice on this? Any help greatly appreciated.

Thanks,
Rod

zabooda
04-13-2012, 04:06 AM
A lot has been said about windshield spread and I fixed mine wine another screw on the top frame.


http://www.moomba.com/msgboard/showthread.php?13687-windshield-spread&highlight=windshield

NCSUmoomba
04-13-2012, 09:27 AM
I have done a band-aid job on mine that works really well, and most people don't even notice it. It's in my mods thread.

http://www.moomba.com/msgboard/showthread.php?10662-My-mods-to-the-Ruby-Roo!

I have also removed my windshield before as well. When I bought my boat, the glove box lid was not mounted, and apparently, they are installed before the windshield. To get it off, all you have to do is remove the plastic strip in the bottom piece of the frame. This will expose the screws that hold the frame down. Unscrew those and the windshield will come right off.

iwaterskihard
04-13-2012, 10:23 AM
The attachements don't show up for some reason? Yet If I log out and open the forum they show up. When I click on them it asks me to log in. So I do and as soon as I do...................no pics??????

KSmith
04-13-2012, 12:52 PM
The attachements don't show up for some reason? Yet If I log out and open the forum they show up. When I click on them it asks me to log in. So I do and as soon as I do...................no pics??????

Same thing happens when I try to view the attachments...

NCSUmoomba
04-13-2012, 01:13 PM
Maybe they got lost on the information superhighway, it does the same for me. I will dig them up and repost them.

NCSUmoomba
04-16-2012, 09:23 AM
Here are this pics I posted and a few more I took for another member.

NCSUmoomba
04-16-2012, 09:24 AM
5 pic limit, here are the last two.

iwaterskihard
04-16-2012, 03:52 PM
Thanks for the pics. What did you use for the outside piece or catch on the folding pane? Looks like aluminum from a screen door or something?

NCSUmoomba
04-17-2012, 02:05 PM
Its just a flat piece of aluminum. I got the aluminum pieces at the local home improvement store. I used automotive foam tape to adhere the pieces together, and some foam rubber weatherstripping for the gasket. Good as new.