PDA

View Full Version : Mildew on deck of Outback LS



moombaschleg
06-21-2005, 11:19 PM
I will try to upload this picture I took after taking our boat our of storage. I bought a new Outback LS and have had problems with mildew on the back deck since day one. I have the gray and red 'wave' pattern, and cover it with a factory Moomba cover. It seems that moisture must get trapped between the cover and the vinyl on the back deck....every year more than last, and the black remains from the first year. Even my dealer tried a heavy duty cleaner to no avail. This boat is totally babied, not a scratch....but there is this mildew stain. Has anyone else had the same problem? I have considered a new custom cover, but really don't want, nor think I should have to pay the money for it. Even if I begged for a warrantied replacement, I don't feel real comfortable it wouldn't return.

Any comments or suggestions would be helpful.



Thanks

Wes

IndianaCannot get the file to upload. Email Schlegelmilch99@yahoo.com for pictures. Thanks!

MEDIC151
06-22-2005, 09:27 AM
I have the exact color pattern and the exact same problem. Some of the mildew gets under the vinyl and will stain from the back side. I found that if I use something to prop up the cover to keep it off the back deck it stops this from happening. I use an inner tube standing vertically right behind the engine cover keeps it high enough to stay off the back deck. As far as removing the stain from underneath, if you find something, let me know.

Medic

moombaschleg
06-22-2005, 05:54 PM
Thanks for the reply. This is the only real problem I have come across, though is it very frustrating. My 94 Rinker never had am issue like that, and it was nine years old. I'll try the innertube bit.......doesn't it alter the fit of the cover?

Have a good week

Buttafewcoe
06-23-2005, 07:03 AM
Fantastic cuts mildew pretty good. I had a few spots develop fom winter storage. They were small, not wide spread. Anyway, Fantastic did a good job. Left no stain. I think the literature even says it's ok to use.
.
Hope this helps
.
Jim