PDA

View Full Version : stiff throttle



AZ_Calling
06-22-2005, 01:19 PM
I recently purchased a '03 Mobius direct drive. This is the only Moomba boat I have driven. The throttle has always been stiff, but I figured that is just the way it is suppose to be. I went for a ride in a Mastercraft this week and the throttle was very smooth going in and out of gear and made driving a lot more enjoyable.

Do others have problems with a stiff throttle and is there an adjustment that can be made to loosen it up?

Thanks

carsondoc
06-22-2005, 01:54 PM
It should not be stiff. Should be very smooth. Take it back to the dealer and have him adjust it or replace it.

clark
06-22-2005, 02:02 PM
My 05 Mobius LSV is very smooth.

Clark

AZ_Calling
06-22-2005, 04:42 PM
Has anyone ever adjusted it themselves? I would think it would be pretty straight forward.

smokedog2
06-22-2005, 05:24 PM
Throttles have springs and things that pop out when opened (at least my Lund did). Not something to take on lightly - fore warned is fore armed.

SD2

Buttafewcoe
06-23-2005, 08:07 AM
The cable on the Bayliner I used to have got stiff. I ended replacing it. So far, I haven't had an issue with my Outback

Dave A
06-23-2005, 10:35 AM
Mine throttle is fairly stiff, I just thought is was an economical form of cruise control.

WakeMe
06-23-2005, 03:55 PM
It is possible that it is the linkage on the transmission cable that is the problem. You can try taking the linkage off right at the tranny and then see if the throttle is easier to move. That was my issue and it was an easy fix.

psq80
06-23-2005, 05:01 PM
When I had my 20 hour service completed a couple of years ago my boat came back with a stiff throttle. I asked the dealer what happened to the throttle because it was fine before I brought it to them. The service center manager looked at it and the cable had been hooked up incorrectly on the back side. It took the service center manager all of 5 minutes to switch it around. So have your dealer definately look at the back of the throttle.

OnTheH20
08-01-2005, 12:03 PM
The throttle on my '05 LSV was always a bit stiff...right up to the time it stopped working! With our first boarder of the day in the water, we took out the slack, gave it gas and the boat lurched before going to idle. The engine ran fine, the boat would go in gear but nothing for speed.

I knew it was the throttle cable but everything looked fine; the throttle level, two sets of linkage and the Perfect Pass. We called the dealer from the water (Atlanta Marine) and they walked me through some diagnostics. Turns out a THIRD linkage in under the engine cowl. That had come undone.

We reconnected the linkage, tightended everything up and the boat drove better than before. The "stiff throttle" was a result of the linkage being too near the end of the threads. Shifts like butter now PLUS I know what to look for if it starts sticking again.

Thanks Atlanta Marine!!!

Buttafewcoe
08-01-2005, 12:41 PM
Don't cha just love it when the fix is simple:p