PDA

View Full Version : What would cause my speedo to stop working?



ian ashton
05-22-2012, 10:58 PM
'08 Outback, Indmar 325, MoombaCruise

The adjustment knob does nothing, speedo sits at zero.

Thoughts?

rsinger
05-22-2012, 11:02 PM
'08 Outback, Indmar 325, MoombaCruise

The adjustment knob does nothing, speedo sits at zero.

Thoughts?


Wait, I know. It's broke.

Mine was the transducer and paddle wheel under the boat. I had to replace it. Only way I knew is there was no voltage coming from the wires as the wheel was spun. However I have 2 speedos and both were doing the same thing.

jmvotto
05-22-2012, 11:40 PM
You bought the PP, it got pissed...

wolfeman131
05-23-2012, 12:13 AM
My guess is your paddle wheel assembly is broken or just gunked up from sitting in the water all the time. You can check voltage as suggested above.

ian ashton
05-23-2012, 08:16 AM
Do I check voltage at the gauge, or wheel? Any idea which wire is the signal?

wolfeman131
05-23-2012, 09:17 AM
OK, Ian - take this for what it's worth, which ain't much more than the scum you scrape off your boat. . .

I believe that the paddlewheel "spokes" have magnets in them and as they are spun by the water flow, they go past a sesnor coil which in turn sends an electrical signal to the speedo. So, I'd try and test it from inside the boat right at the wires coming from the sensor. You'll need an extra set of hands as someone will need to watch the voltmeter while another spins the wheel from under the boat. I would suggest your lovely bride be given the job inside the boat and you the other. :)

wolfeman131
05-23-2012, 09:21 AM
Ian,

Scanning the above posts led me to another thought on how you might trouble shoot and eliminate one failure points. Have you installed the PP yet? If you haven't and can stand the wait, install the PP and see if you get a mph reading onit. If so, I'd say something is up with the speedo itself. If no mph on the PP, I'd say the paddlewheel/sensor is your issue like rsinger above. Might just need to be cleaned up, might need to be replaced.

ian ashton
05-23-2012, 09:45 AM
The speedo not working doesn't really bother me, we set the cruise based on RPM, I just don't like to have things not working. I tried to dive and check the paddle wheel last night, but I couldn't hold my breath long enough to find it, lol. I presume that this is a job that will need the trailer, lol. I'm just trying to gather info at this point for where to start.

The PP is shipping from Canada, so I suspect it will take a while, but its GPS based, so I'm not sure if it uses the paddle wheel at all - truth be told I have done just about no research on the Stargazer system, haha.

Worst case scenario I'll have the dealer fix it if I can't figure it out, I just hate doing that - either they charge me to pull out the sub box, or I have to do it myself - both of those options suck, haha.

wolfeman131
05-23-2012, 09:50 AM
OK, so you're right that PP won't help. Maybe try the checking at the sensor while out on the lake? I have a feeling the sub box will stay in place and that your issue is with the paddlewheel/sensor.

I'm with you in that I may not need something, but I want it to work.