PDA

View Full Version : Blown Bass sounds from tower



eblom
09-05-2012, 03:20 PM
I have the stock Kicker system that came on the 2008 LSV (2 amps, a ZX200.4 that powers the 6 Kicker cabin speakers and a ZX250.2 that powers the 4 KM620.2 tower speakers) I was getting a blown bass sound from some of the tower speakers so I bought some replacement NOS KM620.2's and the system sounded great for 2 weeks... Now I am back to the blown bass sounds again and I am wondering whats going on... The stock system is fine for me and my family but I dont want to keep swapping out the tower speakers... Should I get a different (resonably priced) tower setup or can the speakers I have be repaired somehow? Is the ZX250.2 too much for these speakers? I am an audio novice so any help is appreciated...

kaneboats
09-05-2012, 03:57 PM
It's possible it's not enough amp and you're pushing it too hard. My 250.2 would barely power my two cheezy kenwood speakers on the tower. I swapped it out when I got my 4 Exile SXT's.

MLA
09-05-2012, 04:09 PM
Sounds like the amps cross-over filter is set to "OFF". Needs to be "Hi-Pass". Check this before swapping any more gear.

eblom
09-05-2012, 08:53 PM
I checked the crossover switch and it was on HI but I switctched it to off & thrn back to HI in case it messed up somehow... Then I tuurned the bass boost down toabout 12:00 & I think the prob went away... I cranked the sytem as loud as I could in mydriveway & all good... Thanksfor the help!

philwsailz
09-06-2012, 04:47 PM
Bass boost on the tower amp should be totally off!!!!! Your high-pass crossover limits low frequencies, so having bass boost on is idisyncratic. One part of the amp turning the bass down and the other turning it up is not the way to run that amp.

Where was bass boost on the tower amp set prior to your turning it to 12:00? It is probable that you found what was causing your speakkrs to sound bad.

Again, turn bass boost totally off for the tower speakers.

Phil
Kicker

eblom
09-06-2012, 04:58 PM
It was at about 3:00! I bought the boat last year and I suspect the original owner had messed with the settings... Is there any documentation on all the original settings from the factory for 2008?

philwsailz
09-06-2012, 05:15 PM
I don't have setup sheets from then any more. Mine go back to 2010.

In general for a tower amp:

BASS BOOST Off
CROSSOVER SWITCH Set to HI-PASS
CROSSOVER FREQUENCY, (Hz) somewhere between 100 and 150
GAIN I seem to recall for the old-old set up that the gain should be at ab out 11:00 as looked at as a clock dial...


Does that help?

Phil
Kicker

eblom
09-06-2012, 05:23 PM
It sure does... Thank you... Can you suggest any settings for the in-boat speaker amp? Thanks for your help...

philwsailz
09-06-2012, 05:27 PM
It sure does... Thank you... Can you suggest any settings for the in-boat speaker amp? Thanks for your help...
Similar settings... with these exceptions:

crossover set to 80-90

Bass boost still set to off for the coax speaker amp channels

If a subwoofer is in the boat, a litle bass boost is okay, but typically not more than about 10:00 as viewed as a clock dial... Subwoofer gain seems like it was at about 12:00