PDA

View Full Version : Heater problems in the summer?



zabooda
08-08-2005, 02:48 AM
Had an experience in the middle of nowhere where my heater started to leak. I thought I was tracking in too much water but the water was hot, much hotter than the 100 degree temperatures. It was leaking about a gallon an hour and appeared to be coming from the core itself as the connections on top are dry. When I got home I put a bypass hose on until I can fix it and I'll probably carry a hose in my rig from now on. I had to do some mopping each time I went out as I didn't want to pull a hose or cut one. I found out one good thing about having a subwoofer in the cockpit panel...access to the heater! I guess I'll see if a radiator repair shop can fix it when I get it out.

Flatwater
08-10-2005, 02:22 PM
What year ? How Many hours ? Salt water ?
A few things come to mind - not fully winterized or damaged from gear or stereo installer or loose calmps. The most common time this occurs is first outting of the season. Let us know if the rad shop can repair.

zabooda
08-10-2005, 08:30 PM
I'll let you know how it turns out on the 98 Mobius. I've got about 375 hours on the boat and there was no exposure to salt water. The system worked fine until last week so the winterization wasn't a problem. Heatercraft has redesigned their cores from an automotive type to a "S" type with fins that allows the water to flow through it better. The minerals can build up and the pH of the water such that it eats away at the core. The case looks in good shape with no dents either. Just one of those things. Statistically, everything has a failure rate and mine accounts for all of you (99%) who have operational systems. When I read some of the posts, I'm glad it isn't problems with the engine or the boat in general.