PDA

View Full Version : CD player Problems



05mobiusxlv
09-26-2005, 04:04 AM
For the first half hour cd player works fine. For the next hour or so, it turns on and off constantly. Especially when the volume is loud. I have also noticed it turning off when i touch the wakeplate control. Sometimes it comes right back on, sometimes it takes a couple minutes. After a couple hours its fine for the rest of the day. Dealer told me to check the connections on the power box under the dash, they were all tight. Does anyone have any idea's? It has done this the last 4 times i have had it out.

smokedog2
09-26-2005, 10:20 AM
Id guess lose wire and the loud vs plate etc. is coincidence. Id check the battery connections and the voltage at the battery to be sure that is normal.

I bet you have a lose wire behind the radio, at the distribution box, or maybe at your radio switch. If you can read and us a voltmeter it will help. If not take it to dealer and say , here ya go.

Check for a lose fuse as well.


SD2

Rugburn
09-26-2005, 01:51 PM
I added a thicker guage wire for power to the head unit and connected it directly to my battery switch. That cured any problems with turning it too loud and cutting out.

05mobiusxlv
10-02-2005, 01:28 AM
Found the Problem, Loose Nut on a thick red wire in the distribution box. Found a couple more loose connections as well. I guess that should be expected when the factory 10 inch sub is directly below that box. Skiers Choice needs to invest in some loctite when they put these boats together. It seems like every bolt and screw in the entire boat has vibrated loose or off. Oh well, i still love her. Thanks for the help!