PDA

View Full Version : Check Engine Light



jntMobiusLSV
03-18-2013, 04:02 PM
Just took our new 2013 Moomba LSV out the other day for the 2nd time. I noticed the "check engine" light came on after we had it out for a couple of hours. Boat seemed to be running fine despite the light coming on. Only thing I did that could cause the light to come on is I left the blower on for most of the ride before realizing it was still on. The stereo turned off on its own while I was driving the boat. I switched over to the 2nd battery and the stereo worked fine. Never had any problems starting the engine back up after the stereo went off, even when using the 1st battery. All gauges were normal on the dash, including battery voltage, the entire time. My question is this: Would the battery losing voltage like that trigger the "check engine" light to come on? I talked to the dealer and they seemed to think that is likely what caused the "check engine" light to come on. Anybody else experience anything like this before?

04OUTBACK
03-18-2013, 04:14 PM
low voltage would def shut the stereo and could be a cause of check engine light. Three Full cycles of the engine resets the Check engine light if there is not further fault.. (cold start, warm up. turn off.. let cool off completely and restart)
Thats not real easy to do at home unless you have a water connection... but that is what is required to manually reset it.
How close is dealer? id sure take a 2013 in for check up just in case and they can reset.

jntMobiusLSV
03-18-2013, 07:05 PM
Thanks for the input. I am planning on taking it to the dealership tomorrow (30 miles) and have them look at it just to make sure it's not anything major.

jntMobiusLSV
03-22-2013, 10:12 AM
It was in fact low battery voltage that had caused the check engine light to come on. One of the dual batteries was actually almost completely drained. They put a new battery in for me and told me I need to turn the dual battery switch to the "2nd position or both batteries" so it will keep both batteries charged all the time. Said that's how it was "wired up." Took it back out and it ran fine. No check engine light is on now.