PDA

View Full Version : Front Ballast Loosing Water



05mobiusxlv
07-25-2006, 10:39 PM
I'm sorry to ask this again, hopefully someone out there can help me out. I have taken it to my dealer, they have called skiers choice 10 times on it, and no one has answers.

I fill up my front sac, 15 minutes later, 1/4 of the water is missing, If I wait 30 minutes, 1/2 the water is gone. Rear bags stay full always. The front compartment is always dry. We put a new fill valve in (located on top of the tranny) that didn't work. I hooked up the front hose to a valve that controls one of the rear bags, it still went flat, so I'm sure its has nothing to do with the fill valve. But what else could it be??

When I fill the bag, I let it fill until it starts running out the side port. When I hit the switch to stop filing, water still comes out the port on the side of the boat for about 30 seconds. It might keep coming out the port when I start driving, i'm not sure. The only thing I could think of, was if it has some kind of pressure regulator that wasn't working, but my dealer said it didn't. Could it be anything with the empty pump? That's all that is left, that I know about.

It has done this since day 1. I have put up with it for 200 hours now. It does it every singe time. All that skiers choice can tell me is to keep the pump running the entire time, but i'm not settling for that, I look dumb with water pouring out the side of my boat all the time.

AZ_Calling
07-26-2006, 12:10 PM
I was thinking it was a bad check value too. If you think about it the water can only go out the empty port and/or the fill port. If the empty pump is not running (and no water is coming out the side port) we know it must be coming out the fill port.

My guess is you don't have a check value or it is broken (if it was installed backwards, the bag would never fill)

I agree with you that running the pump is not a real solution. The life of the pumps are to short to be running all the time.

Good Luck.

05mobiusxlv
07-28-2006, 02:17 AM
Thanks guys. I went out again today, and when the front bag gets 100% full, water starts coming out the side port (normal). I shut off the pump, and the water kept coming out the side for a couple more minutes. Does anyone know where this check valve is located? Like I said before, this is my second fill valve. And a month ago, i swapped the front hose to a different fill valve, and it sill lost water. So hopefully this valve is located in or by the empty pump.

I called my dealer today, and told him to call skiers choice and ask them about the check valve. So hopefully next week we can get this problem fixed. Thanks again.

AZ_Calling
07-28-2006, 05:01 PM
I think we might be overloading the term "check valve". When I say check valve I mean a value you would put inline (between the fill pump and ballast tank). The valve issures that water only runs 1 direction. Therefore you can pump water into the ballast but water can not come back to the fill pump.

I would bet your check valve is not by the empty pump, I don't think you have to worry about water getting into the ballast thru the port hole on the side of the boat (if that is the case you have bigger problems)

I don't beleive SC puts check valves into their ballast systems. I have a '03 Mobius LS and my boat does not have a check valve.

zabooda
07-29-2006, 05:06 AM
I am in an area I'm not totally familiar as I don't use bags (old school - slalomer) but aren't the pumps a positive displacement where the pump acts as a check valve? Which would say the discharge pump may have an internal leak where the water siphons out.

Brian Raymond
08-01-2006, 12:35 AM
The aft end may be sinking lower than the ballast bag, and causig the water to siphon out. This can happen with oversized bags in the rear. The one way to fix this, would be to have the front bag drain out just behind the horn cover. This would require some minor plumbing of the drain hose, a new thru-hull fitting, and sealing up the port drain outlet. Brian Raymond