PDA

View Full Version : Swim platform mount bolts stripped



Ghostrider
07-27-2006, 02:33 PM
The bolts that hold the fiberglass swim platform mounts are stripped. Has this happened to anyone else? Is there any way to fix it? The screws on my wake plate are also loose/stripped. Any easy fixes for either of these? I was thinking about using a two part epoxy and shooting it in the holes and then tightening the bolts back in. Good idea or not such a good idea?

smokedog2
07-27-2006, 04:48 PM
Is it the glass or the metal that is gone?

Glass is easy, rebuild with a patch kit. Metal would be harder.

SD2

Buttafewcoe
07-28-2006, 11:20 AM
Actually, on my '04 Outback DD, there are nuts on those screws. I noticed a little play on one of the mounts, so I removed the carpet (one against the transom) and did a little investigating. It was a close fit, but i was able to get a 5/16" wrench down in there to hold the nuts while I tightened the screws.
.
Hope this helps
.
B

cj11302000
08-02-2006, 01:58 AM
I had a problem with my 05 Outback when someone stepped off the teak swim step and I heard a crack. The mounts had come loose...I took the carpet off the ski locker area and was able to tighten the nuts but the fiberglass was cracked. Luckily it was covered by warranty and the dealer had it sent to a fiberglass shop to have it repaired. You should do what butta says and check the back side.

cj11302000
08-02-2006, 01:59 AM
I had a problem with my 05 Outback when someone stepped off the teak swim step and I heard a crack. The mounts had come loose...I took the carpet off the ski locker area and was able to tighten the nuts but the fiberglass was cracked. Luckily it was covered by warranty and the dealer had it sent to a fiberglass shop to have it repaired. You should do what butta says and check the back side.