PDA

View Full Version : Perfect Pass install



SethC
08-03-2006, 11:30 PM
Anybody have any experience installing perfect pass on a newer model Moomba? I have an 05 XLV and I'm basically done except for the under dash wiring. It appears that it's prewired but obviously I can't check it until I get in the water and well I don't want to spend the day on the lake under the dash.

There is a 2,3 and 4 pin wiring harness coming off of the perfect pass module box. The three pin connecter appears to have the power and raw rpm I found an open plug under dash and it powered up the guage. There is a 2 pin harness open under the dash as well it has a brown and white wire. I think this may be coming from the paddlewheel but not sure and lastly the 4 pin harness is open but that is the one from the removed spedometer which has power and obviously paddlewheel info as well.

Does anybody know if it's as simple as this?

JoeTechie
08-04-2006, 01:32 AM
Oh Ed ????

;)

-J

YellowMoomba0
08-04-2006, 09:43 AM
Ed stop picking on me.

I hooked up only what would fit via Harness. Guess I got lucky. Any other loose wires I think are still loose, I will look under my dash and check; however, I agree that if SC will fax diagram then thats what I would go with.

SethC
08-04-2006, 12:30 PM
Originally posted by YellowMoomba0


Ed stop picking on me.

I hooked up only what would fit via Harness. Guess I got lucky. Any other loose wires I think are still loose, I will look under my dash and check; however, I agree that if SC will fax diagram then thats what I would go with.

When you installed your's yourself did you plug the 4 pin harness into the harness that was vacated by the spedometer? The 4 pin on the module only has 2 wires on it actually and they line up with what I think was the paddlewheel info according to the wiring on the removed spedometer. Like I said before there is a 2 pin harness thats vacant as well I think it's another set of wires coming from the paddlewheel that provides water temp.

Anyway I plugged it all in and turned the key and nothing exploded servo test worked.....when my wife gets home I will have to have her jump under the boat and manually spin the paddlewheel :)

YellowMoomba0
08-04-2006, 03:26 PM
Im not sure if i plugged into the spare harness or the one that was previously used for the speedo i removed. I will need to look and get back to you.

08-04-2006, 04:29 PM
Thanks for your help.....I think I got it right I went under the boat and manually spun the paddlewheel and my wife says the guage showed a reading. It shows a temperature reading and the servo auto tightens when I intially turn the key. Only real question at this point is the RPM connection which was I'm sure will work since it appears that Moomba just prewires the boat for Perfect Pass whether it's a chosen option or not.

I'll let you all know tomorrow what happens.

SethC
08-06-2006, 11:02 AM
Just as a FYI the 05 XLV is basically prewired for perfect pass. Everything worked perfectly. I used the open 2 and 3 pin harnesses and reused the 4 pin from the removed spedometer.

I mainly got this to make it easier on my wife pulling me, but I have to say it makes it much easier to drink a beer and pull someone at the same time without having to worry about maintaining speed. I love it.

YellowMoomba0
08-07-2006, 09:39 AM
Yeah, its quite an addition to the skiing / riding experience. After you have used it you wonder how you got along without it. I love mine too. So much so that I am considering putting a picture of it on my desk right between photos of my dog and my wife.