PDA

View Full Version : No hot water coming out of shower



Rugburn
09-19-2006, 07:36 PM
I was fooling around with the shower and notice that I dont get any hot water coming out. I feel the red hose is warm right up to the valves. When I have only the hot valve open, nothing comes out. Just the cold open, cold comes out, both open, still just cold. Anybody else have their valves go bad? I know its not essential equipment but Id like it to work just the same.

Brian Raymond
09-20-2006, 12:00 AM
Rugburn, if your hot water supply is coming from the block, you may have some debris (dirt,rust,sand) build up in there, and it is letting little water through to the valve but with no pressure. Remove the hose from the barb, and on a fake-a-lake, start the motor, see if you have a steady stream coming from the barb. If you do, check the hose at the dial. If you don't, take a drill bit 2 sizes under what will fit in the barb, insert and turn counterclockwise, by fingers, while the engine is running, until the debris comes out. Once a steady stream happens, hook the hose back up and happy showering. Keep us posted. Brian Raymond

mvd
09-20-2006, 04:30 AM
Originally posted by Rugburn


I was fooling around with the shower and notice that I dont get any hot water coming out. I feel the red hose is warm right up to the valves. When I have only the hot valve open, nothing comes out. Just the cold open, cold comes out, both open, still just cold. Anybody else have their valves go bad? I know its not essential equipment but Id like it to work just the same.

What kind of type of Moomba did you got the Shower. I am planning to install one myself so any information, manuals, types of showers, place to install is welcome. :)