PDA

View Full Version : THANKS for all the posts on Impeller replacement



04OUTBACK
02-26-2007, 08:41 AM
Guys,
After reading through the message board this weekend on all the Posts regarding Impeller replacement, I set out to replace mine Sunday. (04 Outback DD wit 108hrs.) ALL the tips on here were a big help. WD-40 to lube, Bumping the ignition to get it to move some, needle nose pliers...
All great help. It did not take 30 minutes! Thanks. I installed a flush pro back at Christmas and got to try it out yesterday. It was great to hear her run, although I wanted to go run her in the lake! Hoping the Groundhog is correct! :lol:

Thanks again for all the help. This Bulletin Board has been very helpful to me.
BW
Madison, MS

Buttafewcoe
02-26-2007, 08:50 AM
I have the same boat and have the impeller changing (once said part is in hand) down to about 20 minutes. I guess that makes it a 2 beer job, right?
.
B

04OUTBACK
02-26-2007, 02:12 PM
At least a 2 beer job!
Curious. There was an O ring and a gasket in the box. I replaced the gasket on the cover to the water pump.. Where does the O Ring go?

Thanks.

Buttafewcoe
02-26-2007, 03:25 PM
Some of the covers that take the same impeller, but may be like an after-market housing, have an o-ring groove, and the o-ring would be used in place of the gasket. The shaft that drives the impeller, where it comes out of the little pump housing takes a seal and is different from an o-ring or a gasket, so I don't think it goes there.
.
Hope this helps
.
B