PDA

View Full Version : engine temps?



bobwells
03-10-2007, 08:24 AM
Hey Joe Tech, I remember when I first got my boat '98 mobius and mentioned temp was running about 175-185, you suggested replacing raw pump impellor. I did this, (it needed it had broken impellors and chewed up) I also replaced the circulatory pump. changed thermostat (160 deg) i still run bout the same temp. when the boat is idleing in between pulls it will began to rise to bout 185 or so then its as therm opens and falls to around 160-165 then it may start easing back up again. when running at 2-3k it stays bout 175-180... reckon this is bout as cool as she's gone get? thanks, bob just wasnt sure if there was something else I need to ck. ?got great oil press.

JoeTechie
03-11-2007, 04:29 PM
Doesn't sound too bad too me. Make sure you change that impeller every 2 years or so too. Check it yearly. They go bad and they are so cheap to replace.

-Joe

Buttafewcoe
03-11-2007, 07:51 PM
Make sure there are no pieces of the old impeller restricting any flow. I don't know if the boat you have has a trans cooler before the thermostat, but if it does, check to see there are no obstructions on the inlet side where the water feeds it. I agree w/ Joe, though....doesn't sound too bad.
.
Hope this helps
.
B

bobwells
03-11-2007, 09:58 PM
thanks guys, was out today and all seems well, had an absolute gorgeous day, bout 80 deg.my son has abandoned the wet suit, water temp bout 70 so i guess spring is officially here in nth. fl. all yall on the north side hang on its coming! have a super week, all... :D