PDA

View Full Version : replacing bilge pump



hwb06
04-15-2007, 04:23 PM
the bilge pump is broken and needs to b replaced on my 04 lsv. There is very little room to work. any suggestions to make the process a little easier

smokedog2
04-15-2007, 06:23 PM
I have never done this on a SC boat BUT

Generally (maybe not here) they are on a mount to the floor and can be twisted and disconected, undo the hose and buy the exact pump to use the same floor mount.

Right tight left lose I think.

SD2

zabooda
04-15-2007, 08:37 PM
If the housing is OK then you may get by with replacing the pump motor mechanism which usually snaps into the housing unit and splice in the wires. It worked on my 99'.

hwb06
04-15-2007, 09:02 PM
actually there is an issue with the housing and the internals... there just isnt much room to work to replace the pump and i wasn't sure if any one had any tips.

smokedog2
04-15-2007, 09:57 PM
I'm not sure how a housing goes bad.

On my Lund I often take it off, wash the crud out in the lake and put it back. Be sure the thing is realy broke and not just jammed with a piece of junk.

I'm not sure where mine is on teh Moomba.

SD2

hwb06
04-15-2007, 10:06 PM
well one of the platic ears that holds the top down has been snapped since we got it, so when the top pops up it pops the float switch too

seanpatsdad
04-15-2007, 11:31 PM
Are you going in from the engine area or the V-Drive access?Mine was right there when you take off the V drive access.You may have to take off the main water inlet line for easier access.
John

hwb06
04-16-2007, 01:32 AM
great guys thanks buyin a new one tommorow let u no how the replacement goes!