PDA

View Full Version : Moomba Swim Platform nightmares



KamberraRick
06-04-2007, 04:14 PM
I own a 2000 Moomba Kamberra, and I have experienced several problems with the swim platform brackets coming loose from the transom of the boat. I have had it repaired twice, but have had the same problems. The problems are that the way the platform brackets are engineered, there is no access to the bottom bolts, (or in this case, lag screws). There are 4 pieces of hardware holding on each swim platform bracket. The top two pieces of hardware are actual bolts that I have access to to tighten when they get loose. The bottom two pieces of hardware are lag screws that screw into the fiberglass. My problem has been that once it has been fixed and re-glassed around the bottom lag screws, they always end up loosening up when water backs under the swim platform, thus making the boat un-operable due to 2 holes in the transom for each bracket. Has anyone heard of this problem in a Moomba, or expeirenced this problem at all? I live in San Antonio, Texas, and I'm the second owner of this boat, so I don't have any dealer contacts in this area. Any help would be much appreciated, due to my frustration levels with this problem. thank you.

Buttafewcoe
06-05-2007, 06:53 AM
All bolts and nuts on my '04. Difficult to get to. I had to tighten them all at the end of the season last year b4 I put her away for the winter hibernation. Noticed Sunday eve one was a little loose. I'll have to snug er back b4 I go out again.
.
If possible I'd replace your lag screws with bolts. Re glassing seems like it could get expensive
.
Just a thought
.
B

bergermaister
06-06-2007, 12:29 PM
If you do replace your lag screws with bolts, use a locking nut (or two if you can fit a longer bolt) and also use the permanent style loc-tite thread sealant on them. A neoprene washer on either end will help keep the water out.

I've got some spider cracks around the mounts on my '01 but nothing is lose and the cracks are very minimal/surface only; I'm keeping my fingers crossed. Probably from too many sqatters off the back of the boat at once...