PDA

View Full Version : Moomba Boomberrang



maureenwormsbecker
06-28-2002, 04:38 PM
I have a Moomba Boomerrang, last year made. I have been experiencing a terrible time with leaks ever since my water intake was changed. I have triple checked everything...no hull cracks, tightened up the screw thing etc. Any ideas?
This results in my auto bildge going on when moored and the battery dying. Very frustrating..I've paid $350 so far and the problem is not fixed.

Lochrie3
06-29-2002, 10:00 PM
I have a 2000 Boomerang and went through the same problem. After resealing and rechecking everything i could find, i never had any luck until last fall when i was flushing my boat in the driveway. i had the panel behind the engine cover off and notice a hairline crack in the passenger side muffler right where the 2 mounting clamps are. So, the thing would only leak when running, hard to find! I took the muffler out and laid some fiberglass strips and lots of resin mix over the crack and haven't seen any problems after about 10 hours this year. May not be your fix but good thing to check out!

dmgx
07-12-2002, 09:27 AM
Also check your shaft packing where the shaft comes through the boat sometimes it needs to be tightened so it drips 2-3 drips per min. Jay Warren

Alan Metcalf
09-10-2002, 02:12 PM
I had the exact same problem when I bought my used 2000 Boomerang from the dealer. The mufflers were leaking, causing the boat to fill with water. The dealer replaced the mufflers and the problem went away. Theyt were scorched and cracked on the bottom side where you couldn't see it. The dealer said it was caused by overheating the mufflers because the impeller got plugged and so the engine heat went up. He suggested that you should always keep an eye on the temperature gauge and stop the boat if the temp gets above 180 degrees in order to unplug the water intake.