PDA

View Full Version : 2006 Outback w/ 310 Assault Carb Problems



WaterRoo
07-16-2007, 05:50 PM
So far this year I have only been able to put about 7 hours on my boat due to various problems. After having a fuel pump replaced and a float changed out in the carb, I am still having issues. First couple of times out after getting it back the boat ran fine. Short trips 45 min to an hour. Now it will run okay for a while and then stalls out every time I put it in gear. Or, if I am crusing at about 25 mph I will suddenly lose power for a little bit and then it will recover.

Pulled the flame arrestor and during one of the times it was running rough, it appeared that gas was dripping from one of the booster venturis and causing the engine to flood out. Once it stopped dripping it ran fine. I pulled the sight plugs on the carb and the fuel level appeared to be okay if not just a little low. Choke seems to be working okay as well.

If I play with the throttle a little, I can get past the rough spot to a point where the butterflies are open enough it doesn't flood out. Docking or putting it back on the trailer is a nightmare however.

Not sure why I don't have the problem all the time. It will run great for a while and then poorly. Or poorly at the beginning and then start running great.

Frustrated with my dealer who is 2 plus hours away and not anixous to be without my boat for another three weeks. Just looking for some thoughts.

Thanks

csumerall
07-17-2007, 02:32 AM
Just out of curiousity have you added any sort of fuel stabilizer? and also how is the boat running at an idle

WaterRoo
07-17-2007, 07:31 AM
Stabil in every tank. Sometimes it idles fine, other times it is very rough and continuously stalls out.

csumerall
07-17-2007, 11:01 AM
hows the air filter

WaterRoo
07-22-2007, 11:52 AM
Air Filter/ Flame Arrestor is clean.

Y2K_Kanga
07-22-2007, 07:25 PM
I'm having a similar problem. Replaced the fuel pump yesterday and now I have fuel coming out the vent tubes. Would the incorrect pump {Too much PSI cause this?} Boat ran well until the fuel pump quit.

Thanks