PDA

View Full Version : Fuel Pump replacement



VdoManZ
07-17-2007, 05:58 PM
So I replaced the filter. Problem still not solved. I am pretty sure it's the fuel pump now.
I've got the 5.7L Indmar Carb motor.

can i put an autograde pump on to get me by this week? Auto stores carry fuel pumps with the same specs as the Carter pump that is failing.

http://store.summitracing.com/partdetail.asp?autofilter=1&part=CRT%2DP4594&N=700+4294836965+115&autoview=sku

I'm thinking something like this will do until i can get a "marine grade" one ordered. any red flags on using a standard fuel pump?

lowdrag
07-17-2007, 06:14 PM
Your problem sounds very similar to what happened on my '03. The funny part was that as soon as we took the pump off of the mounting bracket it worked fine. I think there was something with the way the mounting bolts were tightened that caused it to start acting up similar to what you described. I still had the dealer replace it but I think it would have worked fine if we had put it back in the boat.

VdoManZ
07-18-2007, 01:08 PM
I still need to know if a car grade fuel pump with the same specs will work? I assume it will however I have not tried.

update... now the boat runs for about 1 hour just fine. when we stop to change skiiers or swim for a few min it will not restart. If i take a screw driver and tap the fuel pump fairly hard it spins back up and the engine runs like a top again. 1 time yesterday it died after about 1 hour of towing when pulling a skiier (32 mph). It seems to only act up after it sits for a long time or if it has been run non stop and then is shut off for a min or two.

VdoManZ
07-18-2007, 01:16 PM
http://store.summitracing.com/partdetail.asp?part=CRT-P4389

I found a winner!!!! the auto parts store down here can order a direct replacement. and it will be in tomorrow morning!

VdoManZ
07-14-2008, 02:34 PM
I forgot to update you all last year.
The new pump installed at beginning of this season fixed ALL issues!

byronkoz
07-16-2008, 06:35 PM
How many hours did you have when the fuel pump failed?