PDA

View Full Version : Water Pump Leak



tlrowe
08-13-2007, 01:37 PM
I think I already know the answer to this, but I thought I would throw it out there to see if anyone has any feedback. I've got a small leak that appears to be coming out of the raw water pump. It's been there for a while and doesn't appear to be getting worse. The engine temp is stable. Just curious if it is normal for some water to coming from there or not. Is there a gasket that needs to be replaced maybe, or might I need to replace the water pump? Thanks for any input.

2000 Kamberra with v-drive.

Buttafewcoe
08-13-2007, 03:22 PM
The tell-tale leak is a sign of the bushing going bad. If it's not getting any worse, you prolly can run it a while longer, just check occasionally.

I take it, it's the water pump on the motor, not the impeller pump.
.
The impeller pump has a seal that can be replaced, also. Just presses out and the new one presses in.

tlrowe
08-13-2007, 03:47 PM
Thanks Butta. To be honest I'm not 100% which pump is which.

http://www.cometconstructionsoftware.com/images/pump.gif

If I posted the image link correctly and you can see it, the leak is coming from the backside of what you see in the pic, right in the center.

Thanks for the help.

seanpatsdad
08-13-2007, 10:41 PM
There is a gasket on that cover.Reach back there and see if the screws are tight.
John

Buttafewcoe
08-14-2007, 03:51 AM
Impeller pump, right. The shaft that drives the impeller has a seal that's leaking some out the back of the pump housing. If you have an Interstate Bolt and Supply or similar, they are about 4 bucks. The dealer on me old I/O wanted to sell me an entire pump for 300 bucks, he wouldn't sell just the seal. Those pumps are real simple and easy to work on. Just be sure not damage or score the pump housing when taking out the old seal or pressing in the new one.
.
Hope this helps.
.
B

tlrowe
08-14-2007, 08:52 AM
Thanks guys.