PDA

View Full Version : Ballast Water Strainer leak



TN_Boarder
05-18-2008, 07:59 PM
During my dewinterization, I pulled the ballast water strainer off and cleaned it out for the first time. I now have a leak arount the top of the strainer housing thats giving my bilge pump a pretty good workout.

Does anyone know if there should be a gasket or o-ring around the inside of the rim of the strainer housing that I may have lost? I was thinking maybe it stuck to the fitting when I screwed the housing off and then fell off into the bilge area afterward but I don't see anything floating around. I'm afraid to really tighten this thing down any tighter than "hand tight" as it is just hard plastic.

Thanks guys.

pickle311
05-18-2008, 10:03 PM
there should be a seal in there, if it's missing it will leak

moomba_armada
05-19-2008, 12:57 AM
A rubber O-ring TN. I did the same when winterizing and it seems the O-ring is a bit bigger and it doesn-t fit in it place and get stuck between the strainer housing threads, I am looking for a new one today.

Good luck

VA LSV
05-19-2008, 08:35 AM
Mine has a square shouldered gasket.

JesseC
05-19-2008, 11:53 AM
Mine has a square shouldered gasket.

I have the same one. Always seems to stick to the housing and fall into the bilge. I also found my 9/16 wrench while looking for the gasket during the dewinterization process.

TN_Boarder
05-19-2008, 01:53 PM
Thanks guys.

I'm gonna search my bilge area and hopefully will find it and maybe even some tools. If I'm not able to recover the old one, does anyone know where to get a replacement?

I don't think I've mentioned it lately, so.............

Man, I love this board and my boat. I still get compliments EVERY time I take my '06 LSV out.

04OUTBACK
05-19-2008, 10:58 PM
Mine is leaking from where the strainer threads onto the rest of the pipes. gotta get some plumbing tape and redo.. caused by removing strainer for winterization...

tlatoani
05-20-2008, 01:10 PM
Mine didn't have the o-ring there (used boat), so I took it around town to find one. None of the hardware stores had one that fit, but one of the pool stores did. It's from a hottub filter.

I didn't want to deal with ordering one, but I'm sure you can.

Razzman
05-22-2008, 10:36 PM
This might help with the sealing issue on the o-ring, go to a pool & spa dealer and get a container of Magic Lube. It's a silicon lube just for o-rings used in pool pumps and such. Dab a tiny amount on the o-ring and spread it around, it will help seal and keep the o-ring in place.